My setup here is several MBPs backing up to an Apple Time Capsule. Backups are encrypted.

  1. I boot to recovery mode on the MBP I want to restore to (Cmd+R).
  2. Choose to restore from a Time Machine backup.
  3. Choose the Time Capsule in the list, and enter its network password. Works fine. I can now see the backups.
  4. Choose the particular MBP backup image I want to restore, and am prompted for its encryption password.
  5. Enter this, but it doesn't work. Wrong password, apparently. Tried repeatedly.

If I boot the MBP normally I can see in Keychain Access that the password I'm typing is 100% correct. No doubt about it.

I made sure to set the keyboard language correctly in recovery mode (it defaults to US English but I'm British). Still locked out.

I can browse the backup just fine when macOS is booted. I doubt the backup is corrupted but, like I say, in recovery mode I'm not even getting far enough to find out. The password for the encrypted backup image just isn't being accepted.

I've had this happen too in the past when I was utterly sure I had the right password, and I ended-up just abandoning the backup and starting with a fresh install. I can't do that here.

Anybody got a clue as to how I can access this backup? Why do I have a feeling I'm encountering one of those serious bugs that Apple knows about but brushes under the carpet?

5 Answers 5


I think I figured this out and it's extraordinary. The issue appears to be that Apple's encryption for Time Machine backups only accepts 12 characters. Yet there's no error message, so you can enter longer passwords than this and it will simply truncate what you type and then record it in the Keychain.

So if you set the password 1234567890123 (13 characters) for an encryption password when initially creating the Time Machine backup, it will actually use 123456789012 (12 characters) and not inform you at any point. And because it's now stored in the Keychain, you will never have to type it again except in an emergency so will never know — until it's pretty much too late. When you need to restore the backup, you type the 13 character password and Time Machine will not accept it!

I think I'm correct here, but I might be wrong. I thought I'd share this just in case it's useful to anybody else.

So the solution:

  1. Ensure the keyboard is set to your nationality (UK or AUS English) by clicking the flag icon at the top right when in Recovery Mode.
  2. Type only the first 12 characters of your Time Machine encryption password. Prob best to write it out and count the characters, and then type it in.

Let me know if this solves your problem.


An update for people in 2019. We had the same problem, luckily we could still access the keychain and check. In our case the password was truncated to 28 characters from the 32 we had written.


Hopefully, my problem is the same, thus my experience may be additive to this.

Mac Mini 2018 fell over, reformated, reinstalled, couldn't get Time Machine to connect to the time capsule. Manually went through the setup process of macOS, creating my account, and such.

Opened Finder, opened Network, opened the Time Capsule, password OK, opened Backup folder, opened the relevant sparse bundle, again password OK.

Please note: I am cutting and pasting the same password. No fat fingers here.

It mounts, I can happily copy files, user folders, from the encrypted time machine backup back to my system manually.

So good news. I restored it manually.

Now I go to set up Time Machine again: System Preferences > Time Machine > select Back Up automatically > select Time Capsule > paste password > asks me if I want to use the existing encrypted > say Yes > asks for password > paste again > incorrect password!

I tried truncating the password to 12 characters, no dice. I checked the Airport Utility: the backup folder says it is protected with the device password. This is consistent with my experience of manually mounting the sparse image with the same password. It is most definitely the password, I have 2TB worth of rescued files to prove it.

What was weird is that through this process, I opened the sparse bundle many times in trying to isolate the problem, and well, sometimes the cut and pasted password would not work and I would have to force disconnect from the time capsule and start all over again.

Perhaps future generations will figure this out.

  • I tried tmutil in the terminal to try and get my mac mini to inherit the old backup. No luck. So I decided to dumbly change the name of my sparsebudle, to keep it as a back up back up.. and set up a new back up. server-old.sparsebundle is what I renamed the old budle to. I then went into the timemachine UI to set up a new back up. It happily found the old sparsebundle I renamed, asked me if I wanted to reuse it, accepted the password.. and off it went.. it automatically renamed the sparse bundle back to original name server.sparsebundle BTW. all my old backups are still accessible. Jan 18, 2022 at 1:52

As of August 2022 and with Monterey 12.5.1, max password lengths for Time Machine appear to be up to 32 characters. I originally set up a longer password via a password manager, and entering just the first 32 chars worked to mount the drive.


Incredibly, here I am 5 years after posting this question and this is STILL a problem.

There is a serious bug in how Time Machine handles passwords for encrypted backups. I don't know the specifics, but I think it's to do with "unusual" characters. The length of characters, as discussed above, appears to be an issue too.

It's happy to accept passwords with unusual characters, or of a certain length, but it will reject them in the future. And that's often the point at which you're attempting to restore the backup! The absolute worst situation.

My advice right now is

  • KEEP PASSWORDS SHORT (e.g. 12 characters at most)

The letters you use should be the standard English alphabet (could this be some Unicode bug...?).

For example, just now my password to connect to a Time Machine backup sparse bundle over the network was rejected repeatedly (I also copied and pasted directly from the keychain entry – still no luck). I went over to the "backup" Mac storing the sparse bundle, tapped in the password, and it worked fine to unlock it.

So frustrating!

My solution was to change the password of the sparse bundle on that Mac storing it to one that's very simple, with just letters and numbers. This is described in an answer here: What can I do when my Time Machine password is not accepted, although it's correct?. This didn't work the first time I tried it, but after a reboot it did work. I think if there's been any attempt to access the sparse bundle then it won't work, so try the trick immediately after a reboot.

Of course, if it's not a Mac that's storing the backup sparse bundle (e.g. it's a NAS), then your options are limited. You might be able to copy it off the NAS, and onto a Mac, then change the password there, before copying it back to the NAS... but these sparse bundles are, by their very nature, large backups. This is unlikely to be possible for most users.

Apple clearly treats Time Machine as abandonware, with serious bugs like this indicating that it should no longer be included within macOS. A backup tool that can't restore even though the user does everything right is just callously poor software engineering. Shame on Apple.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .