2

We have several Windows-based file shares and one computer can't connect to them. By default, he should be able to use smb://server.name/share from Finder > Go > Connect to Server... and then get prompted for his username and password, but instead he gets an error almost immediately that says:

There was a problem connecting to the server "server.name".

Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.

Here's what we've tried so far in our troubleshooting:

  • Tried restarting the computer
  • Changed the server name to use the IP instead. No change in behavior
  • Confirmed that the server name and IP can be pinged
  • Tried using cifs:// instead of smb://. No change in behavior
  • Confirmed there aren't any saved credentials in Keychain Access that could be outdated
  • Confirmed we get the same error when trying to connect to different servers with different shares and using different accounts
1

I solved a similar problem on my computer a while ago. I created a file /etc/nsmb.conf with the following contents:

[default]
signing_required=no

Be aware that you disable some security features with this procedure. You can find more details in an apple support article.

  • What a great resource to pass along! I was really hopeful this would solve the problem, but alas the issue persists. – bmkaiser Jul 24 '18 at 14:31
1

Found the answer here: https://apple.stackexchange.com/a/262136/296316

Person had the Android development tools installed and so this was affecting their access to SMB shares. Removing the com.intel.kext.intelhaxm kext resolved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .