I had Python accessing a password from the keychain, configured to "Confirm before access" but not "Ask for keychain password":

enter image description here

Which worked fine. Every time the script wanted the password, I needed to click the "Allow" button in the dialog. The keychain password was never asked.

The only thing I did was to update to the latest Sierra security release 10.12.6, and now the dialog keeps asking the keychain password every time, even if the configuration is still the same as the image above.

I deleted the local keychain, I deleted ~/Library/Keychain. The user account password and the Keychain passwords are the same, so this is not the fix.

And the same happens with the other application that I have accessing the Keychain: git, configured to use the osxkeychain for credentials. I have to type the Keychain password all the time now.

How can I get the dialog to stop asking the Keychain password? It was working before updating to latest Sierra.

I don't want to enable "Always allow access to this application" because I don't think is secure, even if it solves the annoying password prompt.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.