2

I'm running a mid-2012 MBP with a WD green SSD inside. I needed to install Ubuntu for university so I tried to do so via a live USB. While doing the installation I accidentally clicked on the option to erase my entire drive and install Ubuntu but I pressed back as soon as I saw the partitioning wizard show up. So it shouldn't have done anything, right?

I then clicked on the other option which allows you to install on a specific partition, but noticed that I had a bunch of these Linux partitions that I haven't made. After rebooting I found that I can no longer boot to macOS. After some googling I found someone else with the same problem.. They claim that the Ubuntu installer:

overwrote a whopping 2MB of the APFS container without confirmations or warnings

Their solution was to format and reinstall macOS. I unfortunately have some important notes on there that I hadn't backed up, is there any chance that they could be recovered?

I already tried using disk utility in internet recovery, but it just tells me that in order to repair the drive I need to "run disk utility in recovery", which is nonsense as I'm already in recovery. After some more googling I found that using diskutil through command line could work, but after running diskutil verifyDisk /dev/disk1 and diskutil verifyDisk /dev/disk1 I get the error message:

Error: -69767 This disk doesn't contain an EFI system partition; if you want to start up your computer with this disk or include it in a RAID set, back up your data and partition this disk

Which leads me to believe that I need to remake my EFI partition? This is what diskutil list shows:

terminal

It goes all the way up to disk19 with tiny <5mb partitions.

You must log in to answer this question.

Browse other questions tagged .