URLs have long been the domain of web browsers, but some apps challenge this assumption by asking your browser to open a link in their dedicated app.

Problem: Safari Keeps Asking Permission

For example, I use Zoom.us, a videoconferencing service. They give me a link associated with my conference call that's easy to throw into a calendar invite, like https://ibm.zoom.us/j/9747900418. When I click the link, my browser opens it, authenticates me, and asks me permission to open the link in zoom.us.app, which I've already installed.

Dialog asking to open a page in zoom.us

Click Allow on the dialog shown by your browser
If you don't see a dialog, click Launch Meeting below

Do you want to allow this page to open "zoom.us.app"?
Cancel | Allow

After opening hundred of meetings this way, I'm sick of it asking me permission. I want Safari to remember that it's allowed to open zoom.us/* links in zoom.us.app.

What I've Tried

Under Safari > Preferences > Websites, I escalated privileges for Zoom-related items:

  • General > Auto-Play > ibm.zoom.us was "Stop media with sound"; set to "Allow Auto-Play"
  • Plug-ins > Zoom Launcher 3.0.1 > ibm.zoom.us was "Ask"; set to "On"
  • Plug-ins > Zoom Launcher 3.0.1 > support.zoom.us was "Ask"; set to "On"

This had no effect. So how can I get Zoom links to open correctly?


4 Answers 4


Sad 2022 update:

Support for client URLs (e.g. the zoommtg:// protocol) apparently has been deprecated.

If you have an older Zoom client, it likely supports zoommtg://; but for security reasons, it's not wise to continue using older versions.

Original answer:

Have you tried rewriting the URL so that it uses the zoommtg:// protocol?

You rewrite a URL of this format ...


... like this:


If you have the Zoom app/client installed on a Mac, using URLs with the zoommtg protocol should cause them to open directly in the Zoom app, no matter where the URL is clicked from. Personally, I use this URL format in the Notes field of Calendar events, and it works great.

  • 1
    Hm, I can't quite get the integrated link password to work. The client always prompts from the passcode. Commented Nov 11, 2020 at 16:28
  • Are you manually updating the URL each time?
    – LHM
    Commented Jun 25, 2021 at 15:13
  • If it's a new meeting with a different URL, then yeah, I'd have to manually edit that URL to change it to the zoommtg:// format. But generally the meetings I do on Zoom are scheduled, so I only have to edit it once, then I add it to a calendar event and set it to repeat daily/weekly. I never touch it again.
    – Kirkman14
    Commented Jun 25, 2021 at 21:25
  • 1
    This feature is now deprecated: marketplace.zoom.us/docs/client-url-schemes :( Commented Dec 30, 2021 at 15:21
  • Well, bummers. Everytime I need to enter my uni. programme's Zoom room, I have to open my university's Intranet and navigate 3–4 pages to find the link and pressing it, leads to another page asking if I want to open Zoom ... just a pain in the butt. Now when URL scheme is gone, what to do? I wish I could save the current room in Zoom for later.
    – Henrik
    Commented Jan 3, 2022 at 23:58

Various extensions for the browser and chatbots allow you to open Zoom links directly:

  • 2
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Nov 10, 2021 at 11:00
  • 1
    Alpaca only works if the URL is shared inside of Slack or MS Teams; the OP wants to know about Safari. Commented Dec 30, 2021 at 15:24
  • ZoomIn is currently maintained here: github.com/ocastx/ZoomIn
    – ThomasW
    Commented Sep 20, 2022 at 4:18

Safari 17, available now in beta includes an "Always Allow" option. After the first prompt, it will automatically open those links without waiting for user input.

Safari 17 Prompt with "Always Allow" option


I don't think it can be disabled...but...if the application you want to use is already running (or is in the dock), you can drag and drop the link onto the application's dock icon to avoid the dialog.

I just did it with a magnet link and Transmission and it did not invoke the dialog (I know, at the cost of a drag...which is...a drag).

  • Great idea (and nice pun), but dragging a link onto the application icon doesn't work with Zoom.us.
    – Merchako
    Commented Aug 2, 2018 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .