1

I downloaded a dmg for Docker from their website and when I try to run it, it opens a window with the name of an application I installed earlier

Window name says Franz for Docker

The title bar says Franz 5.0.0-beta18 which is something I installed earlier. If I try to move the application icon to the Applications folder, it fails with error 43

Error code 43 on moving to Applications Folder

The sidebar in my Finder then shows an icon for the mounted dmg but without the usual Icon. Clicking on this icon prompts that the item this links to cannot be found

Original Item cannot be found error

I tried ejecting this faulty dmg to retry but there is no retry option in the context menu, only an option to remove this icon from the sidebar.


Is this issue because of something wrong the application I installed earlier (Franz) or is it unrelated to that? I deleted the dmg for that application and that does not help.

  • What browser did you use to download the Docker dmg? And, have you tried restarting your Mac and opening the dmg file again? – Monomeeth Jul 17 '18 at 11:34
  • I downloaded the Docker file using Chrome. I logged out of my Account on the Mac and logged in again but that did not change anything. Did not try a reboot yet. I was hoping for a solution without having to do that. – Sinstein Jul 17 '18 at 11:39
  • Ok. As a test, how about moving the dmg file to another location and then use Safari instead to download it again and see if the new dmg works? – Monomeeth Jul 17 '18 at 11:45
  • I deleted the existing file and downloaded again from Safari. Still the same outcome. I tried to install docker cask via brew and that worked. The logs show that the dmg brew download is different from the dmg I get via browser (at least the paths are different). I downloaded the one brew uses via the browser to see if that works but that did not. Infact opening any other dmg causes the mounted folder to show the name of the previous dmg. – Sinstein Jul 17 '18 at 11:56

You must log in to answer this question.

Browse other questions tagged .