2

This question already has an answer here:

iTerm2 always closes the tab/window on error. By contrast, Terminal keeps it open so you can view the error.

How can I prevent iTerm2 from automatically closing the tab/window on error?

marked as duplicate by Allan, IconDaemon, nohillside Jul 17 '18 at 14:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Thanks that helped. I fixed it by unchecking the setting under Preferences -> Profiles -> Session -> Automatically close a session when it ends – allsap Jul 17 '18 at 13:08
  • Glad I could help. Even though it's a dupe, I up voted (to send you some reputation points) and hope that you leave the question here so there's another avenue for people to find the answer to this type of question. – Allan Jul 17 '18 at 13:10

Browse other questions tagged .