I'm having issues resizing my main disk in APFS.

Got a new SSD disk which is double in size.
I decrypted my harddrive via FileVault.
I took an image of my old hard drive onto a external hard disk.
Swap the old SSD with the new and booted via a Mac OS X USB installer and restored the image onto the new SSD.

Now everything works perfect and the only step left was to increase the partition size from ~250 to ~500GB.

In the USB Installer mode I ran the command diskutil apfs resizeContainer disk0s2 0.

The first time I ran it it kept writing our errors on the dstream with a hex-inode number.
I hoped that it was just a file or folder which was corrupted so I converted the hex to the inode ID and removed the folder (some kind of tmp slack/google driver folder).
But it kept on giving me errors on the dstream.

All this was while the operation Checking the fsroot tree and produced errors similar to this
warning: invalid dstream.default_crypto_id (0x0) for encrypted volume, given apfs_fs_flags (0x8) (not the real error message but looked similar).

And some tries, I ran the above distil apfs resizeContainer command again and now it produced another error
Error: -69743: The new size must be different than the existing size indicating that my disk disk0s2 was already resized.

This is not the case, it is still on the ~250GB.

The Disk Utility app in High Sierra doesn't give me much answers and UI kinda broken or at least give me very mixed informations.

My Disk setup in Disk Utility looks like this:
- Apple SSD [500GB] - -- Container Disk1 (disk0s2) the one I'm trying to format [250GB] - -- -- OS X (disk1s1) [250GB]

I know APFS might not be that well tested yet and perhaps has been prematurely released by Apple but it really seem unbelievable that a "simple" task to resize the container is not done properly.

I'm currently working on some kind of long term solution to migrate data from one mac to another. Completely format the new SSD disk with 500GB and then migrate system back again but this is a very cumbersome task and shouldn't be necessary.

Any advice or suggestions would be deeply appreciated.

I'm aware that this is a duplicate post from Increase size of APFS partion in High Sierra and Resizing Mac OS partition - macOS High Sierra but the answers their does not provide any solution for this issue and there might have been some changes in APFS within the last 6+ month since these questions was asked.


  • At the risk of Not Answering The Asked Question... If you use a backup utility that can make a bootable backup (CCC, SuperDuper, etc) you just format the target drive and restore the backed up data, no messing with partitions. – Steve Chambers Jul 17 '18 at 19:29
  • Hi Steve, thanks for your answer. I'm currently just doing a time machine backup and then my goal is to completely wipe and reformat my harddrive. I still hope to get an answer to this but I think I'm at my last resort and do it the good old way – Mestika Jul 18 '18 at 7:04

You must log in to answer this question.

Browse other questions tagged .