Does anyone know, why some compilation albums (purchased on iTunes Shop) sometimes appear as 100s of album covers in the album overview? (as opposed to what one would expect, just 1 album or atleast 1 per CD)

(would have posted a picture here to show what I mean, but I am apparently not allowed to)

And, probably more importantly, what's the fix? I've been meddling around with "compilation" properties on the songs, but that doesn't seem to help much. This is really annoying me lol, almost to the point of me considering just deleting the albums only to get rid of this... hoping someone has an alternative suggestion ;-)


It's possible the "Part of a compilation" meta data wasn't set for these tracks. You can group them together as a single "album" in iTunes by:

  1. Selecting all the tracks you want to come from the same album (use Cmd-Left Click to select multiple, non-contiguous tracks)

  2. Hitting -I to bring up the meta-data editor window and then:

    • For the Album Arist field enter: Various Arists
    • For the Album field enter the name of the compilation album
    • And then make sure the Part of a compilation option box is checked
  3. Click OK to apply the changes to all the tracks

You should now see them grouped together in the grid view as one album, all showing (hopefully) the same cover art. If they're not showing the same cover art:

  1. Find the cover art you like.
  2. Copy it to the clipboard with -C
  3. select all the tracks again and open the meta-data editor window.
  4. Click once in the Artwork window and hit -V to paste the cover art to all the tracks.
  5. Click OK to add the cover art to every track in the compilation.
| improve this answer | |
  • Hope apple make this the default, this has been driving me bananas. Thanks! – adolf garlic Feb 4 '12 at 11:37

The reason why there are so many covers is that each song comes from a separate album hence the 100s of album covers.

The fix would be to remove each song's cover art (I believe it has to be done for each song manually) and then applying a new image in bulk for all songs. To do so, select all songs, then (command-i or Ctrl-i on windows) and then drop the artwork onto the big white square on the right of the dialog that just popped.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .