2

I have MetroPCS. I set up my greeting earlier this week. I had bad reception so called their support and they 'reset the network'. Now I can't save my voicemail greeting. I get this error. I took the phone to a MetroPCS store, but they couldn't fix it. They only called tech support too. How do I fix it?

Also, my visual voicemail is not showing new voicemails. I manually called my voicemail by holding down 1, sent a voicemail message to myself, and hung up. It doesn't appear in visual voicemail.

I also called my phone from another line and left a voicemail, but it doesn't show up or notify me of a voicemail.

iPhone 5, iOS 10.3.3.

  • I know you don't want to hear this but if I was you I'd find a MetroPCS store and take it in for them to work on it. – Steve Chambers Jul 12 '18 at 23:10
  • I did that, but they couldn't fix it. They only called the tech support number themselves. – Chloe Jul 12 '18 at 23:13
  • Did they try the usual "turn airplane mode on, wait 30 seconds, turn it off"? Also, did you see them do the network reset? I'm just wondering if they did it correctly. – fsb Jul 12 '18 at 23:43
  • If the above doesn't work, try resetting your voicemail password: Settings > Phone > Change Voicemail Password. – fsb Jul 12 '18 at 23:46
  • They turned the whole phone off and on again. Yes it happened after I used Settings > General > Reset > Reset Network, but it could have been something they did on their end earlier today ('network refresh'). I tried airplane mode for 30s, but it didn't work. I tried to change voicemail password, and it gave an error: "Voicemail Unavailable. Unable to connect. Try again later." – Chloe Jul 13 '18 at 0:03
1

Voicemail needs to be activated by carrier. I too had same problem, phoned my carrier and they activated it so I was able to record my greeting. Problem solved 🙂

  • I had to switch from MetroPCS to ATT because they couldn't fix the problem. They are so dumb. – Chloe Oct 23 '18 at 18:37
-1

Go to Setting -> Phone -> Change Voicemail Password

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .