3

I tried to turn on AFP access logging on macOS Server 5.6.1, but don't see any entries when accessing the volume from clients running macOS 10.13.5

My AFP settings list as serveradmin settings afp

afp:maxGuests = -1
afp:afpTCPPort = 548
afp:clientSleepTime = 24
afp:replyCacheQuantum = 32
afp:maxConnections = -1
afp:sendGreetingOnce = no
afp:reconnectTTLInMin = 1440
afp:clientSleepOnOff = yes
afp:loginGreeting = ""
afp:errorLogPath = "/Library/Logs/AppleFileService/AppleFileServiceError.log"
afp:errorLogTime = 0
afp:activityLogTime = 7
afp:errorLogSize = 1000
afp:kerberosPrincipal = "afpserver/LKDC:SHA1.XXX@LKDC:SHA1.XXX"
afp:recon1SrvrKeyTTLHrs = 168
afp:idleDisconnectOnOff = no
afp:reconnectFlag = "no_admin_kills"
afp:activityLog = yes
afp:reconnectKeyLocation = "/private/etc/AFP.conf"
afp:loginGreetingTime = 1315436086
afp:adminGetsSp = yes
afp:fullServerMode = yes
afp:idleDisconnectMsg = ""
afp:updateHomeDirQuota = yes
afp:serverStoppedTime = 1530836567
afp:activityLogPath = "/Library/Logs/AppleFileService/AppleFileServiceAccess.log"
afp:authenticationMode = "standard_and_kerberos"
afp:admin31GetsSp = no
afp:shutdownThreshold = 3
afp:TCPQuantum = 1048576
afp:allowSendMessage = yes
afp:idleDisconnectTime = 10
afp:loggingAttributes:logOpenFork = yes
afp:loggingAttributes:logDelete = yes
afp:loggingAttributes:logCreateDir = yes
afp:loggingAttributes:logLogin = yes
afp:loggingAttributes:logLogout = yes
afp:loggingAttributes:logCreateFile = yes
afp:tickleTime = 30
afp:specialAdminPrivs = no
afp:noNetworkUsers = no
afp:idleDisconnectFlag:adminUsers = yes
afp:idleDisconnectFlag:registeredUsers = yes
afp:idleDisconnectFlag:usersWithOpenFiles = yes
afp:idleDisconnectFlag:guestUsers = yes
afp:recon1TokenTTLMins = 10080
afp:guestAccess = yes
afp:allowRootLogin = no
afp:activityLogSize = 1000
afp:afpServerEncoding = 0
afp:createHomeDir = yes

Looking at the specific text logs above in an editor and looking in console app, I can’t find any sort of obvious AFP service logging.

What needs to get changed to log the date and time when an AFP share is accessed through this server?

  • 1
    Which specific problem are you trying to solve here? Do you have access issues over AFP (or another problem) which you try to analyse via log files, are you just wondering why the logs are empty, or something else altogether? – nohillside Jul 12 '18 at 11:43
  • @nohillside Many thanks for your reply...the sharing work as aspected - the users can connect and no problem with the service on the network in general, but the logs file still empty...the same behavior in another fresh install of OS X 10.13.5 whit the same config for AFP settings – Jonathan Bellieri Jul 15 '18 at 10:29
  • I've edited and reopened your question. Feel free to add anything back in case I removed too much. – nohillside Jul 15 '18 at 11:38
  • Good edits! I'm guessing you invoked some serveradmin settings command to dump your AFP text? Also - would you edit to explain how you are checking logs? Tailing one specific file or are you using the log command to process the stream / database as opposed to just inspecting the remnants / portion of logging that end up on the filesystem? – bmike Jul 15 '18 at 12:13
  • @bmike exactly, I've use serveradmin settings afp command to dump parameters - I've try to check logs with console.app and by simply open with Atom IDE a dedicated files for access and error but not entry found...for the log stream, googling I've found: log stream --info --debug --predicate='process="AppleFileServer"' and this command works as aspected, ther terminal show the oparetions produced by connected user to afp shared folders but the files AppleFileServiceAccess.log and AppleFileServiceError.log still not present any event. – Jonathan Bellieri Jul 15 '18 at 12:51

You must log in to answer this question.

Browse other questions tagged .