Let's say I have two spaces with a program open in space one. If I'm actively working in space two and open a file that uses the same program as what's open in space one, I get hucked back into space one. How can I make the default behavior be to open a new window of the program in the space I'm in?

3 Answers 3


This will help users running Lion but won't solve your problem in Leopard.

In Lion, there is a Control Panel setting under Mission Control that says When switching to an app, switch to a space with open windows for that app. Deselect it. Note that when this option is deselected, if you click an app in the Dock with open windows in another space, on the first click you will get your desired behavior, but if you click the icon in the dock again, it will switch to the space currently containing windows for the app.

enter image description here

  • Sorry, missed the Leopard tag.
    – Daniel
    Dec 5, 2011 at 16:29

Found an answer on Macworld.com

You can achieve the same thing in QuickSilver with and some basic AppleScript:

tell application "Safari"   
   make new document    
   tell application
   "Safari" to activate 
end tell

Simply save this AppleScript somewhere that QuickSilver will find it.

The good thing about the above AppleScript is that it doesn't mess around with focus (which can inadvertently switch Spaces). Unfortunately not all applications have a similar AppleScript command for making a new window (for example, Terminal does not).

I saved mine in my home directory, and called it "New Safari Window". I also changed it so that it had the Safari icon (by dragging the Safari icon from the "Get Info" window of Safari.app, to the icon in the "Get Info" window of the new script file).

  • So I guess it's not possible? I'm looking for a cross program solution, not just a select few. Like the last comment on that page says, "The thing I would really like is how to turn off this behavior. That is, I want to change open space ONLY when I explicitly ask for it."
    – Chords
    Dec 5, 2011 at 15:39
  • Yes, I'm afraid this feature is not build into MacOS...
    – Michiel
    Dec 5, 2011 at 15:54

Type the following in Terminal:

# don't switch spaces automatically
defaults write com.apple.Dock workspaces-auto-swoosh -bool NO

Then killall Dock.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .