1

I have a Mac Mini that I use as a build platform, from within Visual Studios 2017 for Windows, to write and debug iOS apps.

I've noticed that when I establish a connection between VS and the Mac, I have to log into the Mac remotely (I use TigerVNC) before launching the connection process. If I don't establish a remote desktop session on the Mac, the connection will fail part way through because the Mac has gone back to sleep (i.e., the power LED has gone dark).

This is a different behavior than what I'm used to when accessing a Windows machine remotely. For them, once you establish a connection, the machine stays awake until the connection is closed, and the sleep timeout period expires.

Is this by design for Macs? Is there a setting that I can change to make it stay awake without first creating a desktop session?

  • 1
    Normally your Mac should Wake-on-LAN if your network/router supports it. Last time I used VNC software, I had to attempt the connection twice: the first would wake my Mac, and the second would actually connect. That may not be ideal, but worth consideration. – user11633 Jul 10 '18 at 1:41
2

You can prevent the Mac from sleeping in the Energy Saver preferences panel. There are a few options, but if you want to simply keep it awake the either:

  • Dragging the Computer sleep slider to Off.
  • Checking Prevent computer from sleeping automatically when the display is off.

You can find more options and details in Apple’s Support Document.

  • Thanx. But that option doesn't exist when I bring up Energy Saver (I'm running High Sierra 10.13.5) – Mark Olbert Jul 9 '18 at 15:24
  • 2
    @MarkOlbert you should be able to achieve this by dragging both sliders to the far right -- this will set sleep to never. – bret7600 Jul 9 '18 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .