0

I recently tried upgrading my parents' iMac from Snow Leopard (I think) to El Capitan. It started out all right, but after the first reboot, it became very very slow. That each, each minute remaining on the progress bar took approximately 2 hours. After running for over 48 hours I had to shut the computer down (by holding the power button). Since then whether I try resuming the installation, booting the recovery partition or booting an external bootable USB of the El Capitan installation disk, I get the same thing, which is that the boot progress bar gets slower and slower, taking several hours to reach the end, and then nothing further seems to happen.

I've tried resetting the PRAN. Makes no difference.

I'm thinking this must be something in the hardware, and the next step would be to remove the hard drive and test it using a different computer.

But maybe someone out there has other suggestions?

I would add that I have a time machine backup of the computer in its last usable state, and quite happy to restore from that. But if I can't even boot a recovery partition, then I'm stuck anyway.

1

Sounds like it might be a dying hard drive. Can you boot the Mac off another system, either an external hard drive or another Mac via Target Disk mode, and see how that runs speed-wise? Then run SMART Utility and see what it says about the internal hard drive

  • Is that not what booting from a USB installation disk basically does? If I could get that to boot, which I would have thought it could do without needing to access the internal hard drive, then I should be able to interrogate the hard drive for errors. But it just won't boot. So I'm still back to removing the hard drive and probing it on a different machine. – Jonathan Jul 5 '18 at 11:40
0

Since your seeing that this happens with booting from USB, this may be an issue with other hardware as well. Apple has User facing diagnostics for this: Hold Option-D while booting to boot over the internet to diagnostics. This should run for 3-10minutes and display any errors detected. If you boot to a question mark or other screen your unit may be too old for internet diagnostics and instead should be booted off the HDD: D on boot.

If you don't receive any errors you can try booting in Verbose Mode Command-V or Single User mode Command-S, you should see text while booting. The messages displayed may indicate if this problem is hardware related or software related. This may be enough to pinpoint what is causing the problem.

Most Apple Authorised repair centers will perform a more in-depth diagnostic on your unit at no charge, this is a 5-10m scan that gives a more thurough report than the user diagnostics. If you check with a technician most would be willing to run this and a more in depth scan for you at no cost.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .