I made a 32768 × 32768 pixel Mandelbrot png, because it's a fun thing to do.

It renders fine in preview, until I attempt to zoom in (which is the whole point of making the image as big as I made it). Unzoomed

When I do attempt to zoom in, it starts to grey out the rest of the image, and if I zoom out again, the rest of the image grays out. Greying out

It doesn't ever load. Is there a recommended way that I could render this large image?

[SPECS]

  • 2017 15" MBP
  • 2.8 GHz Intel Core i7
  • 16 GB RAM
  • Intel HD Graphics 1536MB
  • Radeon Pro 555 2048 MB
  • Image format: .png
  • Image resolution: 32,768 x 32,768 pixels
  • Image file size: 49MB
  • 1
    Would you be able to share the file via Dropbox or similar? – nohillside Aug 9 at 14:04
  • 1
    I agree - providing a link to somewhere we can download the file from would be a great way to troubleshoot this. Also, can you further clarify your graphics card? That is, you mention the Intel HD Graphics, but haven't clarified whether your MBP has the AMD Radeon Pro 555 or AMD Radeon Pro 560 as its dedicated GPU? – Monomeeth Aug 10 at 0:05
  • What software did the render / png? Can we get the file to try out? – bmike Aug 10 at 0:18
  • I've experienced this as well even with PDF files in El Capitan. – lhf Aug 10 at 1:02

I would try to open the image in a brand new user account, you can set that up in System Preferences > Users & Groups or just use the Guest account. If you see different results here it must be something in your profile interfering with Preview.

But I'm betting the preview developers didn't account much for people opening 49MB, 32kx32k images. In the likely chance that this is a genuine glitch you could quickly report it at https://www.apple.com/feedback/ or sign up for a developer account & do a full bug report over at https://developer.apple.com/bug-reporting/.

In the short term I would recommend trying to use a different application to view this. A browser or photo editing application might be a good fit. For an image like this there is also a good chance that JPEG would more efficiently compress it & cause less issues, maybe look into converting it with Photoshop or similar.

  • It took long enough to generate the first time, that I'm not sure I want to try generating it as a different file format. – Derek Halden Aug 10 at 6:10
  • 1
    You definitely do not want a Mandelbrot picture in a lossy format such as JPEG. – lhf Aug 10 at 10:19
  • 1
    Tried opening in a different account with no luck, will file feedback. – Derek Halden Aug 11 at 8:03
  • Have you checked out a different application that can open PNG? Safari may even render this correctly – little tiny man Aug 13 at 18:19
  • I have tried using a browser to open this. Xee from the comment by unknowndomain successfully renders and zooms in, but costs money. – Derek Halden Aug 14 at 0:40

I downloaded the file and was able to reproduce the issue you describe, as others have mentioned you should report this to Apple as a bug.

However in the interim there is a nice little utility called Xee it still takes a lot of time to render but it works eventually, the app is £3.99 for the full version but there is a time limited trial on the website.

Within Xee, I set View > Scaling Quality to Low to improve loading times.

Example of 100% crop: example of 100% crop of the image in Xee

  • This is certainly the closest I've seen to a solution for the problem, but it feels a shame to spend a ton on a computer only to have to spend more on an application that shows what I want. – Derek Halden Aug 11 at 8:17
  • 1
    I mean this is an unusual situation and as mentioned above. Reporting it to Apple will help but it’s going to take time. I don’t see there is any other solution. – unknowndomain Aug 11 at 12:12
  • @DerekHalden Just wondering if this answers your question? – unknowndomain Aug 13 at 22:07
  • I'm going to leave the bounty open for a little longer, just because it misses the mark a little in that it's a temporary solution (free trial limited to 30 days). If nothing better comes up you will get the bounty. – Derek Halden Aug 14 at 0:42
  • 1
    Just of note I managed to open it in Adobe Photoshop CC 2018 just fine and zoom around, one thing I noted was that the PNG has an alpha channel so I removed this for testing, and same issue, but now the boxes are now black, which is the predominant background colour, where as before it was grey, which is actually just transparent. This is kind of leaning towards perhaps a memory issue where the rescaling algorithm is reading the same section of the image over and over again when trying to draw the scaled image. – unknowndomain Aug 14 at 10:04

Not enough power; suppose so. I think your problem can not be solved.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.