The bug:

All of a sudden, my 2013 rMBP often perceives a left-click on my Magic Mouse 2 as a right-click.


  • "Often" ≈ every 30 seconds.

  • I have 2 different mouses: an Apple Magic Mouse 1 and an Apple Magic Mouse 2. The problem persists when using either mouse. (Only one is switched on at a time.)

  • The right-click still functions properly.

  • The built-in trackpad does not have this issue. It still functions properly.

  • I've read that the problem might be somehow related to Google Chrome. But, the problem persists (e.g., in Finder) even when Google Chrome is not running.

  • I've terminated the keyboard-remapping software, "Karabiner." I do not have the purportedly-problematic apps, "BetterTouchTool" or "Magnet," installed.

  • No peripherals are plugged into the computer.

  • As soon as I notice that the left-clicks are right-clicks, I do not touch the mouse for about 5 seconds, and the mouse goes "back to normal"... until it happens again (and the process repeats).

  • I plugged in a wired USB Dell mouse (model # 0CJ339). The wired mouse does not have the issue.

What I've tried:

  • I've disconnected and deleted my wireless keyboard as a Bluetooth device (to ensure that no other Bluetooth device is connected to my rMBP other than my mouse).

  • Turning Bluetooth on and off.

  • shift + ⌥ option + left-clicking the Bluetooth menu bar icon → Debug"Reset the Bluetooth module" & "Factory reset all connected Apple devices" & "Remove all devices"

  • Switching mouse on and off. Recharging mouse.

  • System PreferencesMouse → toggling the "Secondary Click" checkbox and ensuring that "Click on right side" is selected

    • I've discovered another bug that could be related: When "Secondary click" is set to "Click on left side" in System PreferencesMouse, the computer never perceives a right-click (no matter whether the mouse is left-clicked or right-clicked). It behaves as if the "Secondary click" checkbox is not even enabled.
  • Deleting Apple Bluetooth and mouse preference files found in ~/Library/Preferences/

  • Resetting PRAM & SMC

  • Booting in Safe Mode. (The issue still manifests in Safe Mode.)

  • Logging out of the administrator account and logging into the "Guest" user account (where the issue still manifested).

  • Repeatedly pressing the ⌃ control key on the laptop keyboard to ensure that a small piece of foreign matter is not stuck underneath this key. (When I hold down the ⌃ control key and left-click, the rMBP perceives this as a right-click 100% of the time.) Also, opening "Keyboard Viewer" to ensure that my computer does not perceive any modifier keys as being pressed when the issue occurs.

  • I do not have any other lingering Bluetooth devices in the vicinity that might interfere with the mouse.

Is there anything else that I can try, besides reinstalling the OS?

OS X El Capitan, version 10.11.6.

  • This normally happens when your bluetooth mouse battery is about to die, this has happened with me and i recharged the mouse. – Charan Jul 4 '18 at 6:50
  • @Charan I already tried recharging the Magic Mouse. Also, the issue arises with two different Magic Mice. – rubik's sphere Jul 4 '18 at 19:27


I randomly noticed that a three-finger-tap on the built-in trackpad would not pull up the dictionary entry for the selected word (like it used to).

I navigated to:

  • System PreferencesTrackpadPoint & Click tab → and saw that the "Look up & data detectors" checkbox was not enabled.

This was very strange, because this feature has always been enabled, and I never disabled it. I enabled this checkbox, and the "look-up" feature now worked.

But, this immediately made my computer stop perceiving all right-clicks (i.e., right-clicks on my mouse were always perceived as left-clicks).

So, I navigated to:

  • System PreferencesMousePoint & Click tab → and toggled the "Secondary click" checkbox off and back on.

After doing this, my computer has not perceived a left-click as a right-click again.

I still have no clue what caused the issue, or why doing the above solved it, especially considering that, for good measure, I had already previously deleted the com.apple.AppleMultitouchTrackpad.plist and com.apple.driver.AppleBluetoothMultitouch.trackpad.plist preference files.


Fixed!!! I discovered that my iMac showed my old Bluetooth keyboard as well as the new one that I got because I needed a number pad. I removed the batteries from the old keyboard and the mouse is back to normal!

  • Hi, as mentioned in the original post, I had already ensured that there were no lingering Bluetooth devices in the vicinity. – rubik's sphere Feb 21 '19 at 20:26

In my case, I had placed an external keyboard on the built-in trackpad. That was messing up the mouse clicks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .