My iCloud Photo Library was working great, but I ran out of space and it stopped syncing. Now I’ve bought more space and restarted my devices, but it is still not syncing.

How can I get it to start syncing again? I vaguely remember this happening before and having to do something like deleting all photos from my iPad and doing something on my Mac.

Update: I have tried rebooting into safe mode and it still doesn’t sync.

iCloud Photos Preferences

I am running OS X Yosemite.

  • 1
    Have you tried adding a photo to your library, from either your Mac or your iPad (or both)? That may be enough to kick off a sync.
    – user11633
    Commented Jul 5, 2018 at 4:24
  • Yes, I have added a few photos on my Mac and it doesn’t sync to iCloud.com or my iPad, But changes are synced between my iPad and iCloud.com
    – Matt
    Commented Jul 5, 2018 at 13:50
  • Similar: apple.stackexchange.com/q/181979
    – Matt
    Commented Jul 5, 2018 at 16:05
  • 1
    Just let it run its course. It most likely isn’t reuploadig everything, but rather reconciling your local and iCloud libraries. You should be able to verify this by keeping an eye on the photo and video counters at the bottom of your collection. I have this happen to me on occasion when my photo library encounters an issue.
    – user11633
    Commented Jul 5, 2018 at 17:33
  • 1
    If this fixes your problem be sure to post it as an answer to help others who may be having the same problem 😊
    – user11633
    Commented Jul 5, 2018 at 17:35

5 Answers 5


The surest way to resolve this is to create a fresh Photos Library by following these steps:

  1. ⌘ cmd-Q out of Photos.
  2. Go into  → System Preferences → iCloud → Photos Options… and uncheck iCloud Photo Library. iCloud Photos Options
  3. Reboot if you want to be safe, though it shouldn’t be necessary.
  4. Launch Photos with ⌥ opt-click.
  5. Click Create New… and name your new Photos Library. Create New Photos Library
  6. Go into Photos → Preferences → General and click Use as System Photo Library. Use as System Photo Library
  7. Go into Photos → Preferences → iCloud and check iCloud Photo Library.
  8. Wait for your photos to be redownloaded from iCloud.

If you’d rather try to keep your existing Photos Library, follow these steps instead:

  1. ⌘ cmd-Q out of Photos.
  2. Create a backup of your Photos Library.photoslibrary file.
  3. Launch Photos with ⌘ cmd-⌥ opt-click.
  4. Click Repair. Repair Photos Library  dialogue box
  5. Wait for macOS to repair your Photos Library. A full sync should take place once the repair has completed.

Some screenshots courtesy of OS X Daily.

  • 1
    Whenever I "repair" my macOS Photos library, I lose all manually tagged People/Faces.
    – 2540625
    Commented Dec 14, 2018 at 0:12

I was battling this exact issue after scanning in over 50,000 family photos into OSX Photos, (I'm assuming some sort of image corruption in your case).

I already had 40,000 and Photos was working without issue for years.

After importing up 10,000 or so photos I had scanned in as TIFF files, iCloud syncing completely stopped.

Tried to recover my Photos library TWICE, to no avail. Almost every Google, (and Apple support), result on this topic was pretty useless and I'd already wasted two weeks waiting for both of those database recoveries to complete.

So spent some time digging around the Photos app log files and discovered that syncing was failing on certain photos. Not just failing, it just stopped cold and there was no real indication that there was any problem with that specific image.

Turns out my Epson FF-680W photo scanner was adding in some bogus EXIF values into the TIFF files. Specifically:

  • Rotation - Caused Photos to completely barf rotation. I would rotate a photo, go out of the album, come back and it was in a different rotation.
  • Location - Could NEVER add any location. Looked like something was there, but always doing this "checking location" loop.

So, I wiped all the imports I had done and started doing some experiments using exiftool.

In the end I came up with a tried and true set of "default" values that fixed all bogus entries. You'll need to change the environment variables to suit.

        exiftool -P -overwrite_original \
                -XMP-photoshop:DateCreated="${DATE} ${TIME}${ZONE}" \
                -XMP-xmp:CreateDate="${DATE} ${TIME}" \
                -IPTC:DateCreated="${DATE}" \
                -IPTC:TimeCreated="${TIME}${ZONE}" \
                -ExifIFD:DateTimeOriginal="${DATE} ${TIME}" \
                -ExifIFD:CreateDate="${DATE} ${TIME}" \
                -ExifIFD:OffsetTime="${ZONE}" \
                -ExifIFD:OffsetTimeOriginal="${ZONE}" \
                -ExifIFD:OffsetTimeDigitized="${ZONE}" \
                -GPS:GPSDateStamp="${DATE} ${TIME}" \
                -XMP-dc:Description="${DESCRIPTION}" -IPTC:Caption-Abstract="${DESCRIPTION}" \
                -XMP-dc:Subject="${KEYWORD}" -IPTC:Keywords="${KEYWORD}" \
                -IPTC:ObjectName="${TITLE}" -XMP-dc:Title="${TITLE}" \
                -XMP-dc:Subject="${KEYWORD}" -IPTC:Keywords="${KEYWORD}" \
                -XMP-iptcExt:PersonInImage="${FACE}" \
                -GPS:GPSSpeed=0 \
                -IFD0:HostComputer="MacMini" \
                -ExifIFD:ExifVersion=0232 \

Format for critical env values: DATE="2021:06:23" TIME="02:41:32" ZONE="+10:00"

The rest are all free text.

Seriously, this is just plain ridiculous that a modern day application can fail so miserably when values are not "within spec".

After wrestling with this for days, with no real help from Apple or Google results, (and on the verge of completely ditching Photos); I can understand anyone else's frustration.

So here's this post. Hope it avoids a tonne of frustration for people.

Note: For those people who want to monitor their sync progress, I use this.

log stream \
    --color always \
    --style compact \
    --predicate 'process == "cloudd" or process == "cloudphotod" or process == "photoanalysisd" or process == "photolibraryd" or process == "cloudpaird" or process == "bird" or process == "cloudpaird" or process == "Photos"' | \
        perl -ne '
    $last = time();

if (/com.apple.photos.cpl.*?:.*?engine.sync.pushtotransport|com.apple.photos.*?:.*?Generic/) {
    $now = time();
    $diff = $now - $last;
    if ($diff > 10) {

    print("$diff - $_");
    $last = $now;

I only add in the perl bit to give me a nice gap between log entries. You could condense it down to just:

log stream --color always --style compact --predicate '(process == "photolibraryd" or process == "Photos") && (subsystem == "com.apple.photos" or subsystem == "com.apple.photos.cpl")'
  • The log stream one-liner is fantastic to see what's actually going on when the GUI isn't telling you much. Thank you.
    – Harv
    Commented Apr 8, 2022 at 7:30

The Photos app appears to automatically pause syncs to iCloud when your computer is running on battery power. Try plugging in your computer, or alternatively, go to Library > Photos > scroll to page bottom and there is an option to resume sync on battery power.


Thanks so much for this answer. It worked great for me! But I do have one suggestion. Over time, Photos may stop syncing again, so I keep a simple image on my desktop so I can add it without having to hunt around for a new photo. But once Photos starts syncing again, I remove the image. No sense having multiple copies of the same image in Photos.


I’ve recently had a problem with photolibraryd eating a lot of CPU and memory (up to 45 GB), even after upgrading to Sonoma 14.1 and removing the system library.

It turned out the problem wasn’t with my library or my iCloud. What helped immediately was getting rid of


which, from a quick web search, is a library for Shared Albums (I don’t think it’s for Shared Library as it seems to go back a few years).

I moved it to bin - with command-backspace, and force-quitting the photolibraryd in Activity Monitor - then restarted and everything went to normal, with my M2 Pro not spinning fans and not getting warm, once again.

I wish I found out about that other library earlier - only when inspecting the process in Activity Monitor, with Open Files and Ports, I found there’s this other Syndication library.

My full discovery process is at Sonoma Photos.app 14.0 and 14.1 very slow, photolibraryd using 40 GB of memory.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .