23

I can not connect to a single public Wi-Fi hotspot that does not require a password but instead shows a pop-up window pointed to captive.apple.com

The pop-up opens blank with the error "The web page couldn't be loaded"

Any idea on how to fix this?

24

Found a solution! If you get a similar problem like this one:

A problem occurred

The solution is to visit the following URL directly from Safari: http://captive.apple.com/hotspot-detect.html

You should be able to connect immediately.

For some reason, Mojave is not redirecting or opening that page properly, hence the error.

  • How does that work, opening a website on apple.com while the macbook does not connect to the hotel wifi? – Hermann Klecker Oct 22 '18 at 18:09
  • 1
    although this works most the time sometimes I get an error where MacOS just decides it cant get internet and refuses to grab a local ip adress. – Samuel Thompson Oct 23 '18 at 23:00
  • 2
    I didn't use the beta version, but found this problem in the stable version. Oddly, it has manifested in two slightly different ways---on the first boot after updating the login page would not load at all, producing exactly the behaviour in the screenshot, but on the second the login page did load, but the error message appeared on clicking "login" after entering a username and password. – mdp Oct 24 '18 at 13:01
  • 1
    cannot believe this is still not fixed (in 10.14.3, at least) sigh – Joey Connick Feb 19 at 20:14
  • 1
    This didn't work for me but captive.apple.com did – Developer Davo Mar 20 at 20:41
4

To be clear, third party browsers don’t work for me, it has to be Safari.

First tried pasting the url into chrome (my default browser) but no luck. Then pasted into safari - success

  • As a good Apple user, I never thought someone would use anything else apart from Safari as the default browser :) – BNB Sep 7 '18 at 7:09
  • 1
    It worked for me on Chrome. – HungryCoder Dec 13 '18 at 14:35
0

Good news, upgraded to 10.14.4 from 10.14.3 and now it works. I also have Sophos installed not sure if that was at play or not.

See also Mac won’t display WiFi login box after upgrade to El Capitan some of the answers there still work with Mojave, incredibly (like "create a non admin login, then wifi starts working").

You must log in to answer this question.

protected by nohillside Oct 30 '18 at 8:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .