1

I've run into a problem with my Thunderbolt ports on my Early 2013 Macbook Pro (Retina). Neither port will work.

I have a genuine Apple Thunderbolt to Firewire 800 adapter and a Firewire 800 to 400 adapter cable to run to the hardware. It receives no power from the Mac. I tested the 800/400 cable on two other (older) Macs, and the unit shows a link (without the drivers installed). I've also tested the Thunderbolt/Firewire adapter with one of the older Macs, same again, unit shows a link.

The only difference with Thunderbolt I can spot is the firmware version on the older Mac is 25.1, while mine is 23.4. I've tried multiple SMC and PRAM resets with no success. Any suggestions?

(EDIT) I must add that my Mac had a logic board replacement a couple of years back under AppleCare. I also have never used Thunderbolt until now.

(EDIT 2) I've tried a few more things; on the 2011 MBP, connecting via the Thunderbolt/Firewire + 800/400 cable yielded nothing. Connecting the 800/400 cable directly showed a link, and the unit showed in System Information/Firewire. Reconnecting to the Thunderbolt/Firewire retained the link status, but System Information/Thunderbolt shows no device connected.

(EDIT 3) Chatted with Apple Support. They suggested I go to the device manufacturer, or my adapter may not be genuine. As a side question, do Apple supply retailers who are not Authorised Apple Retailers? I purchased the adapter from MightyApe, and cannot find anything suggesting they are an authorised retailer.

  • Any chance you could link to the devices purchased? I would have thought that if MightyApe was retailing counterfeit Apple-branded products that Apple's legal team would have shut them down. – Scottmeup Jul 2 '18 at 10:49
  • @Scottmeup The adapter is MightyApe, and the 800/400 cable is emax – itsTheRoid Jul 3 '18 at 21:10
  • Thanks for the info. What are you connecting to it at the end when you say "to run the hardware", I'm assuming this is what Apple was referring to when you said they want you to go to the device manufacturer? As far as I'm concerned they're the manufacturer of the adapter unless there's some evidence that it's not a genuine Apple product. I'd suggest (if possible) that you try another thunderbolt accessory on the ports that draws power. This should show which of the MBP or your thunderbolt to FW adapter is not passing power through. – Scottmeup Jul 4 '18 at 4:31
  • Sorry that was a typo, should have been 'run to the hardware'. The device I'm connecting to is a Digidesign Digi 003 (audio interface). I don't have another Thunderbolt device, this is the first time I've ever used it. When I say the unit shows a link, I mean the link light on the back is on. I'm not sure if that shows that power is passing through or there is a data connection. Either way, connecting to the older MBP causes this to light, but only if it is connected to the Firewire port first, then reconnected to the TB/FW adapter. From that I gather the adapter is at least partly good. – itsTheRoid Jul 4 '18 at 6:33
  • It might be worth your while taking both your MBP and the adapter to an Apple store or retailer of Apple products and asking if you can test some thunderbolt device that you've researched that they stock. I can't think of another way to eliminate the MBP as the source of the issue without testing a known-good thunderbolt device on it. – Scottmeup Jul 4 '18 at 6:36

You must log in to answer this question.

Browse other questions tagged .