20

I'm using a MacBook Pro with a Swedish physical keyboard, but with U.S. layout defined in System Prefs. However the tilde (~) and plus-minus (±) keys seem switched. The following key combination should produce a ~:

enter image description here

Because the mapping in System Prefs says so:

enter image description here

But it results in a ± symbol.

It seems these two keys (± and ~) are switched somehow. How do I make them work as shown in System Prefs?

7
  • 1
    The 2nd picture appears to be showing some kind of hybrid between US ANSI & UK ISO layouts. US keyboards have no key to the left of Z, UK keyboards do. Tilde is to the left of Z on UK, but left of 1 on US. You might be better using a UK map instead.
    – Tetsujin
    Jul 1 '18 at 8:50
  • @Tetsujin you're right. But switching to British makes no difference, the keys are still swapped. Jul 1 '18 at 9:19
  • 1
    Ah, ok, darnit. I'm out of ideas, sorry.
    – Tetsujin
    Jul 1 '18 at 9:22
  • 1
    The 2nd picture is in fact the US ISO layout, what you are supposed to get when US is used on an ISO keyboard with the extra key. Aren't the keys also swapped when you are NOT holding down SHIFT? Jul 1 '18 at 9:33
  • 2
    Here is a similar question with a couple answers: apple.stackexchange.com/questions/239395/and-keys-are-swapped Jul 1 '18 at 9:40
43

Here’s a solution that does not use any external tools.

Run this in Terminal.app:

hidutil property --set '{"UserKeyMapping":[{"HIDKeyboardModifierMappingSrc":0x700000035,"HIDKeyboardModifierMappingDst":0x700000064},{"HIDKeyboardModifierMappingSrc":0x700000064,"HIDKeyboardModifierMappingDst":0x700000035}]}'

Now try your ~ and ± keys: they should be switched around.

Problem is, this fix will only work until the next restart. To make it permanent, you have to automatically run it on system load.

You can do that in three Terminal.app commands:

  1. cat << 'EOF' > ~/.tilde-switch && chmod +x ~/.tilde-switch
    hidutil property --set '{"UserKeyMapping":[{"HIDKeyboardModifierMappingSrc":0x700000035,"HIDKeyboardModifierMappingDst":0x700000064},{"HIDKeyboardModifierMappingSrc":0x700000064,"HIDKeyboardModifierMappingDst":0x700000035}]}'
    EOF
    

    (This is all a single command.) This stores the script from above in an invisible executable file in your home directory, ~/.tilde-switch.

  2. sudo /usr/bin/env bash -c "cat > /Library/LaunchDaemons/org.custom.tilde-switch.plist" << EOF
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
      <dict>
        <key>Label</key>
        <string>org.custom.tilde-switch</string>
        <key>Program</key>
        <string>${HOME}/.tilde-switch</string>
        <key>RunAtLoad</key>
        <true/>
        <key>KeepAlive</key>
        <false/>
      </dict>
    </plist>
    EOF
    

    (This is all a single command.) This creates a system task: ‘run the file from step 1 on every startup.’

  3. sudo launchctl load -w -- /Library/LaunchDaemons/org.custom.tilde-switch.plist
    

    This loads (activates) the task from step 2.

Steps 2 and 3 will prompt for your password. And now, your ~ and ± keys are permanently switched.

Note 1

This appears to work not only on the MacBook's build-in internal physical keyboard, but on the external keyboards as well.

Note 2

To undo the switching script (not the three steps), here’s the reverse script:

hidutil property --set '{"UserKeyMapping":[{"HIDKeyboardModifierMappingSrc":0x700000035,"HIDKeyboardModifierMappingDst":0x700000035},{"HIDKeyboardModifierMappingSrc":0x700000064,"HIDKeyboardModifierMappingDst":0x700000064}]}'

Note 3

To undo the three steps:

sudo launchctl unload -w -- /Library/LaunchDaemons/org.custom.tilde-switch.plist; sudo rm -f -- /Library/LaunchDaemons/org.custom.tilde-switch.plist ~/.tilde-switch

Credit

This solution is inspired by this article:

http://homeowmorphism.com/articles/17/Remap-CapsLock-Backspace-Sierra

12
  • 1
    Finally! You saved my day
    – phaberest
    May 7 '19 at 22:04
  • This solution works perfectly for my built-in keyboard, however, it unfortunately also affects my Ergodox-EZ, where the key i've mapped to grave now produces § Aug 27 '19 at 4:33
  • 1
    I've tried the fix and it works great! Thanks a lot! Just a small note - it actually affected all my devices, so it works for external keyboards as well (thankfully) and not only for the built-in keyboard as mentioned in the post. Jun 30 '20 at 14:06
  • 1
    @MiroslavNedyalkov I was probably confused on that part when I first wrote the answer. Edited, thanks.
    – CBlew
    Jun 30 '20 at 15:48
  • 1
    Worked for me! Why not putting it however, in .bashrc? Jul 24 '20 at 21:46
15

Using Karabiner Elements, you can add a "Simple Modification" as follows:

"Karabiner Elements Preferences" window, "Simple Modifications" tab, "Target Device" dropdown is set to "Apple Internal Keyboard / Trackpad (No manufacturer name)". Two rows are shown in the configuration table. The first row contains "From key": "non_us_backslash", "To key": "grave_accent_and_tilde (<code>)". The second row contains "From key": "grave_accent_and_tilde (</code>)", "To key": "non_us_backslash".

Basically, you need to know that the name of the § (±) key in Karabiner's configuration screen is non_us_backslash

In my case, I used this method specifically for the built-in keyboard, leaving my external keyboards unchanged.

1
  • Great software. Love it. Thanks a million
    – KaosXIV
    Mar 19 '20 at 8:37
7

Here is Apple documentation with table containing all the keys and corresponding hexes. https://developer.apple.com/library/archive/technotes/tn2450/_index.html

Initial state is no active key remappings:

hidutil property --get UserKeyMapping
(null)

Remap ~ to §± one way:

hidutil property --set '{"UserKeyMapping":[
{"HIDKeyboardModifierMappingSrc":0x700000035,"HIDKeyboardModifierMappingDst":0x700000064}
]}'

Swap them both ways:

hidutil property --set '{"UserKeyMapping":[
{"HIDKeyboardModifierMappingSrc":0x700000035,"HIDKeyboardModifierMappingDst":0x700000064},
{"HIDKeyboardModifierMappingSrc":0x700000064,"HIDKeyboardModifierMappingDst":0x700000035}
]}'

For removing any remappings back to initial just pass an empty array:

hidutil property --set '{"UserKeyMapping":[]}'
3
  • that's perfect, it worked, and I didn't need to install any apps that require weird permissions! It would be amazing if you included how you discovered the key codes too. Thank you
    – SudoPlz
    Jul 14 at 15:22
  • @SudoPlz Good question. So there is a link in my initial comment. Open that page, scroll down to Table 1 List of keyboard usages and their usage IDs., and here you can find Keyboard Grave Accent and Tilde 0x35 and Keyboard Non-US \ and | 0x64. Jul 15 at 10:49
  • awesome, thank you @gordey4doronin
    – SudoPlz
    Jul 15 at 13:38
2

Building on CBlew's solution, one can do without the extra file (which wouldn't work as-is for a multi-user system). Write a plist file like

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <dict>
    <key>Label</key>
    <string>com.example.setkeyboard</string>
    <key>ProgramArguments</key>
    <array>
      <string>/usr/bin/hidutil</string>
      <string>property</string>
      <string>--matching</string>
      <string>{"VendorID": 5426, "ProductID": 579}</string>
      <string>--set</string>
      <string>{"UserKeyMapping":[{"HIDKeyboardModifierMappingDst":0x7000000e3,"HIDKeyboardModifierMappingSrc":0x7000000e2},{"HIDKeyboardModifierMappingDst":0x7000000e2,"HIDKeyboardModifierMappingSrc":0x7000000e3},{"HIDKeyboardModifierMappingDst":0x7000000e7,"HIDKeyboardModifierMappingSrc":0x7000000e6},{"HIDKeyboardModifierMappingDst":0x7000000e6,"HIDKeyboardModifierMappingSrc":0x700000065}]}</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    <key>KeepAlive</key>
    <false/>
  </dict>
</plist>

then set it with sudo launchctl load -w -- /Library/LaunchDaemons/com.example.setkeyboard.plist.

For generating the hidutil invocation I am using this simple Python script.

0

I had this problem switching to a new macbook (with external keyboard). I fixed it by removing my input source (dvorak) and then clicking on "Change keyboard type..." and getting it to identify my external keyboard again (as ISO european). I then re-added my input source and the ~ and ± keys were swapped back and in the correct place.

2
  • didn't work for me unfortunately.
    – SudoPlz
    Jul 14 at 15:06
  • @user3575439's solution was what worked for me on Dell hackintosh laptop. On macOS Monterey 12.0.1 goto System Preferences → Keyboard → Change Keyboard Type and change to ISO.
    – dm5n
    Nov 23 at 7:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .