1

I have macports 2.5.2 already installed.
I have then installed Gnucash 3.2 dmg from gnucash.org.
When I run gnucash, I have the error:

objc[93365]: Class GNotificationCenterDelegate is implemented in both /Applications/Gnucash.app/Contents/Resources/lib/libgio-2.0.0.dylib (0x10c333670) and /opt/local/lib/libgio-2.0.0.dylib (0x117a41620). One of the two will be used. Which one is undefined.
Segmentation fault: 11

/opt/local/lib/libgio-2.0.0.dylib belongs to glib2 macports package.

If I rename /opt/local/lib/libgio-2.0.0.dylib, gnucash works fine. But this can't be a solution.

I've also tried to set DYLB_LIBRARY_PATH to

/Applications/Gnucash.app/Contents/Resources/lib

But this way I have the error

Segmentation fault: 11

Is there a way to run gnucash while macports installed ?

  • Install gnucash from macports should work. Where are you setting environment variables? I would also say Gnucash.app has not set itself up correctly – Mark Jun 30 '18 at 14:40
  • Macports gnucash doesn't build on my Mac. I've opened ticket #56675. I've used export DYLIB_LD_LIBRARY_PATH="/Applications/Gnucash.app/Contents/Resources/lib";/Applications/Gnucash.app/Contents/MacOS/Gnucash. – Noury Jun 30 '18 at 14:53
  • variables in ~./bash* do not affecrt lainching from Finder etc – Mark Jun 30 '18 at 14:59
  • The macports bufg needs the log as the text says - also try with a plain command line – Mark Jun 30 '18 at 15:03
  • That's what I'm doing. I have a script that exports DYLD_LIBRARY_PATH and then runs /Applications/Gnucash.app/Contents/MacOS/Gnucash. I don't launch anything from the lanchpad, the finder...Furthermore otool -L /Applications/Gnucash.app/Contents/MacOS/Gnucash doesn't show any /opt reference. And env command doesn't show any /opt/local/lib – Noury Jun 30 '18 at 15:12
1

Problem is solved now. I have completely uninstalled macports, removed /opt/local directory, and then reinstalled macports. I tried to install macports gnucash, but it is still impossible. But the dmg gnucash works now perfectly. I have no explanation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .