1

I have a MacBook Pro with touch bar from late 2016. I was using my MacBook Pro normally by watching video's. After a view video's I closed my MacBook Pro and came back later. When I opened it again I discovered that the haptic feedback was no longer functioning.

My track pad was fully functional, I was able to click, to use right button, to use Force Touch and move the cursor normally. The only thing that wasn't working was the haptic feedback. I didn't change anything in the settings.

Screen shot of my settings

A small list of everything I tried:

  • Fully shutdown, and restart
  • SMC reset
    • ^ Control⇧ Shift⌥ Option ⦿ Power while power on
    • ^ Control⇧ Shift⌥ Option ⦿ Power while power off
  • NVRAM reset
    • By rebooting pressing CommandOptionPR and waiting for 20 secs
  • Booting while holding D, gave as result: "ADP000", no problems found
  • Starting in Safe Mode, no result
  • Booting from a USB stick with a clean install of macOS

None of these procedures worked for me. I' hoping that someone who had the same issue knows a fix. Otherwise, I might contact Apple. I'm able to use my MacBook Pro normally but it just bothers me the haptic feedback isn't working.

  • 1
    Run AHT - Apple Hardware Test. Hold D while booting from a powered off state with the AC adapter attached. Hopefully that will generate an error which we can work off of. Also, try booting in Safe Mode (hold Shift while booting) to see if the problem has anything to do with things being loaded at boot. Finally, try installing and booting macOS (don't reinstall) to a USB stick to ensure a clean environment (it's just for testing) – Allan Jun 30 '18 at 13:15
  • @Allan, Thanks for your comment. I did everything you said, but sadly no error generated. Even booting from a clean environment the haptic feedback wasn't functioning. I think its a hardware issue so I will contact Apple Support. – William van Dijk Jul 1 '18 at 22:02
  • @William Did you eventually solve your problem? I tried all of the above with no luck and even changed the trackpad. Sadly even that did not help. – Christopher Sep 27 '18 at 11:36
  • @Christopher I went to an Apple Reseller after I contact Apple Support. They replaced the trackpad for me and everything works now as it used to. Weird that the trackpad replacement didn't work for you. If you've done it by yourself then you might need to contact Apple Support for some help, like I did. – William van Dijk Oct 1 '18 at 15:31

You must log in to answer this question.

Browse other questions tagged .