0

I make an app full-screen on my Mac Mini by pressing the green expand button in the top-left corner of the screen.

This results in the automatic creation of a new "Space" for this app. When I am in Mission Control, I now have two spaces: the Desktop and the full-screen app.

The Mac has one display connected to it. When I turn off this display (by pressing the display's power button), and then immediately turn the display back on, the full-screen app is still on screen. In other words, turning off and on the display does not change anything (which is what I desire).

The problem is that if I turn the display off, wait awhile (around an hour), and then turn the display back on, I am now looking at the Desktop Space. In other words, the active Space automatically changes to the Desktop Space when the display is off for a certain amount of time.

What's strange is that this issue never used to occur until recently (so this might be a High Sierra issue). Also, there is no app open in the Desktop Space that is "pulling focus" away from the full-screen app; I just see my Desktop wallpaper. Also, this happens no matter which application is made full-screen.

Toggling the following options in System PreferencesMission Control does not solve the issue:

  • Automatically rearrange Spaces based on most recent use

  • Displays have separate Spaces

Does anyone know how I can ensure that the active Space will not change to the Desktop space, when the display is turned off for awhile?


macOS High Sierra, version 10.13.5.


  • I have been looking for the solution of similar problem with this, and Up to the current macOS (10.14.2), I could not found any way to change the default position of full-screen application. – z0nam Jan 29 at 5:43

You must log in to answer this question.

Browse other questions tagged .