How do I accept anything from my virtual machine (named vagrant).

Tried to add this row in the /etc/pf.conf: pass in from to where .11 is the vm and the .1 is the host.

But with the config above, it still behaves odd. Yesterday It blocked my mysql connection, and today it blocks my nfs connection.

Right now I have to turn off my firewall each time I need to use the vagrant-vm.

Running nmap -p 22,80,443,3306,2049 says all is open when run from host, and same on vm if firewall is off, but when the firewall is on some ports are filtered, today its nfs.

MacOS 10.13.5 (17F77)

  • Which firewall do you have to turn off? pf doesn't filter packets on the same private network. – Allan Jun 28 '18 at 10:40
  • @Allan "System Settings -> Security & p -> Firewall", is that the same as the pf? – Puggan Se Jun 29 '18 at 7:41

You must log in to answer this question.

Browse other questions tagged .