2

I needed to encrypt a few folders on my MacBook (one of the first of the 'just MacBooks', running High Sierra now, though the problem started under the previous OS). I followed the instructions on https://www.hongkiat.com/blog/encrypt-mac-folder/, basically using Disk Utility to create a .dmg. Right after I created it, I unmounted it and then re-opened it to make sure the process worked as advertised. It did, so I deleted the original, unencrypted folder (which is the whole point of the encryption exercise). The next day, I tried to access this .dmg. It asked me for the password, just as it had the day before. The password is absolutely, positively correct, but it wouldn't accept it. I also tried every way I could conceivably have made a mistake. It just gives me an authentication error, as if the password is wrong, which it 100% is not. I've looked through everything I can find for answers, but they're all either talking about external hard drives (with answers involving wiping them completely or unplugging them), or talking about versions of Disk Utility that offer far more options than mine does (many answers involve sparse bundles, which wasn't an option for me). I desperately need these files - and, as a separate problem, my Time Machine has been acting up for ages, so I don't have a recent enough backup to restore from. Please help!

  • 1
    If your MacBook doen't have a standard QWERTY english keybord, try to change your keybord settings to a QWERTY one and to type again your passworld. I use a AZERTY keybord and one day I set up a firmaware passcode. Later, I couldn't figure out why it wasn't possible to disable it (while I was 100% certain the password was correct). I ramdomly tried to type my passworld as if my keybord was a QWERTY and it worked. – Louis Lac Jun 27 '18 at 12:46
  • Thanks for the thought. I wouldn't have any idea how to set up my keyboard differently, though! – Jocelyn Jun 29 '18 at 7:45
  • Just go to your Mac Keybord settings and choose another configuration for text input! – Louis Lac Jun 29 '18 at 9:26
  • I’m having the same problem. My encrypted folder was actually opened during a storm. One strong lighting bolt, and my power went out. I restarted my iMac hours later and entered my password to open the folder and no luck, I can’t get in, shocked about this. I also know my pw is correct. – brewpixels Jun 24 at 16:32
1

Without backups, all you can do is try variations on your password. The encryption system would be useless if it had a backdoor to circumvent your password.

The password is absolutely, positively correct

I suspect that when you setup the DMG what you actually typed in the password field was not exactly what you thought you typed - and you repeated the error. It is possible to consistently type the wrong password - were you typing very quickly, or were you tired, for example?

Try opening TextEdit and typing in your password many times, see what kind of errors you make when typing quickly, pressing/not pressing shift, variations with Caps Lock set, accidentally pressing two keys instead of one, vary how you were sitting with respect to the keyboard, etc. You can then copy each password variant from TextEdit into the DMG dialog password field to try to open the DMG. Good luck.

  • I was super careful and slow. I've tried all the ways I could have screwed them up (shift, etc). Plus I made two folders, and they're both giving me the authentication error. I've tried using the 'wrong' password on each. No luck. Plus, when I first set this up, I unmounted each of the disks and re-opened them, and the passwords worked just as they should. The next day they both failed. I'm 100% ready to accept user error, but I just don't see how that could be possible in this situation, where I get two separate, super-simple passwords correct one day and not the next. Any other thoughts? – Jocelyn Jun 28 '18 at 10:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .