2

I have a Mid-2012 15" Retina Macbook Pro running 10.13.5 which I have been using my AirPods with successfully since I got them over a year ago.

For some reason, today, when I try to connect them, nothing happens. I've tried rebooting. Un-pairing and re-pairing them. They still work with my iPhone.

I noticed this in the Console when I try to connect:

default 14:21:52.245048 -0600   bluetoothd  ***** Temporarily stopping all scans *****
default 14:21:52.331071 -0600   SystemUIServer  [openConnection] self=0x6080002e3c00 EXPANSION.authenticationRequired=0
default 14:21:52.331518 -0600   SystemUIServer  [openConnection] self=0x6080002e3c00 target=0x60c000279ec0 return=0x00000000
default 14:22:02.659245 -0600   bluetoothd  Create connection failed (0x4) for device: 7C-04-D0-A6-1D-CB
default 14:22:02.659318 -0600   bluetoothd  DaemonHCIEventNotificationHandler_ConnectionComplete - 04
default 14:22:02.661284 -0600   SystemUIServer  Failed to connect to the device: 0x4
default 14:22:04.246890 -0600   bluetoothd  ***** Starting after temporarily stopping all scans *****

Is there some other place I can look to see what may be causing this?

2

Having stumbled upon this article, I tried unchecking "Allow Handoff between this Mac and your iCloud devices" and that seemed to work. Even when I checked it back on the connection seems to be holding. I fail to see what Handoff has to do with Bluetooth but at least it works, for now.

  • 1
    Did you do anything else before changing that setting? I've got the same problem and tried unchecking "allow handoff", but it hasn't helped. – lakenen Oct 15 '18 at 7:08
  • Wow, I actually can confirm that after disabling Handoff I could get it to connect. Then I re enabled it. :shrug: – iign Dec 9 '18 at 19:51
  • WOW, I had my nerves on the verge of cracking and then this worked. Amazing. – Bogdan Alexandru Mar 20 at 19:49
0

I've tried everything that has been suggested, but did not work. So I've logged-out of iCloud and tried connecting again, it worked. Just in case if it makes any difference I have the "Allow Handoff between this Mac and your iCloud devices" UNCHECKED in General Preferences (as suggested by Darrell Brogdon above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .