3

My mbp is stuck on boot and fsck cannot be performed because of:

snap_metadata_val object (oid <aléatoire>): invalid extentref_tree_oid (0x0)

It happens that I have dataless snapshot and if I try to:

tmutil deletelocalsnapshots <date>

I'm getting:

Failed to delete local snapshot '<date>'
  • 1
    I wish I could help, but all I can do is point to a similar tale of woe, as yet unresolved - apple.stackexchange.com/questions/328358/… [see all the links too, they're part of the overall problem]. I think my next step will be to eliminate APFS entirely & see how it goes back on HFS+. – Tetsujin Jun 26 '18 at 10:37
1

It's not entirely clear from your question but you should run

tmutil listlocalsnapshots / 

if one says (dataless), you can delete it, as advised here

Check man tmutil of course too.

should be in form YYYY-MM-DD-HHMMSS as stated at that link.

It worked for me when I was in this situation.

I did not need sudo to do this.

1

I encountered this issue when trying to delete the local snapshot from the Terminal offered by my Mac. The thing is that it booted in "installer" mode and I had to chroot /Volumes/Macintosh HD to be able to run the tmutil commands. The delete however didn't work in this installer mode.

So I had to restart the computer holding Shift to start in safe mode. From there, I could start a Terminal and run the above commands to delete the empty snapshot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .