2

Why is the iMessage screen sharing option not available? What causes it to be greyed out?

(see screenshot, green arrow)

enter image description here

1

Assuming that your contact is an iMessage user, a grayed screen sharing button indicates that he can't receive screen sharing at this time.

He may have disabled screen shaping in the Mac settings for instance, or he may be using his iPhone so he cannot perform screen sharing.

Ask your friend if he is using his Mac and ask him to enable Screen Sharing in System Preferences → Sharing.

| improve this answer | |
  • Yes, screen sharing is turned on. – WalterBeiter Jun 25 '18 at 9:26
1

If your friend has "Do Not Disturb" on, Screen sharing will be disabled. I found this out the hard way. To turn it on and off, you click on the slide-out menu button on the top right of the screen. (it will be greyed out if DO NOT DISTURB is turned on).

| improve this answer | |
0

Make sure the person is signed into iCloud (check System Preferences>iCloud). This fixed it for me.

| improve this answer | |
-1

I was troubleshooting a friends MacBook (Sierra) and could not get my El Capitan to work but my MacBook Air on High Sierra did.... suppose to work on anything over Yosemite.

Sharing On iCloud logged in and Messages sent and received via El Capitan but grey video on my side. His "Invite" from MacBook was live but failed with no error message

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .