1

I tried to install Windows 10 to my iMac 10.13.4, through Boot Camp Assistant, but I failed to complete the process...

The BOOTCAMP partition was created though and I wanted to delete it. I realised I couldn't do it from the Disk Utility app, so I opened up the terminal and ran diskutil eraseVolume free n disk0s5 and the partition was deleted successfully!

After that, I realised that the space the BOOTCAMP partition occupied, wasn't released back to Macintosh HD! I searched around and found this command diskutil secureErase freespace 3 "/Volumes/Macintosh HD". I ran it, and by the time I'm writing this it needs another 15 hours.

Should I stop it? Will it even do what I want? Thanks in advance!

PS: I know it's not ubuntu related, but since Macs are unix based, the answer should be the same

1

From this article it looks like what you're doing is a 35-pass secure wipe of the unpartitioned space.

You might have better luck resizing the existing Macintosh HD to the full disk capacity.

If you try to resize Macintosh HD using disk utility and you encounter an error please update your question with a screenshot of the error, and the output of running diskutil list from a terminal window. Terminal can be found in the utilities folder.

0

You can do it from the Disk Utility app, by selecting "Partition" and then proceeding until you see the pie chart. Then select the Bootcamp partition (alternatively named "Empty space"), and delete it (pressing the "Backspace" key). Then proceeding, so that the original Macintosh HD partition will get resized to the full available space.

PS: Make sure to read the dialogs and window popups as you don't want to erase any content on Macintosh HD in this process, so proceed with care.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .