4

This may take some explaining, so please bear with me.

Mac Pro 4,1/5,1 High Sierra 10.13.5
4 HDs & a boot SSD installed.

Related to Add Recovery Partition to APFS drive? & peripherally to Mac Pro with permanently mounted Time Machine. Local snaps any benefit?
At the point this started I had done nothing [I am aware of] to any of the drives. I was about to investigate switching off local snapshots but hadn't actually done anything.

Out of the blue, Time Machine starts to give errors every time a backup is started...

enter image description here

I ran Disk Utility across all the drives & volumes.
The boot drive, a Samsung 1TB 840 Evo SSD came up clean, but there were 57 snapshots stretching back a few weeks. [I spent some time trying to thin those, but in the end gave up.]

2 of the drives gave this error -

Volume [name] on disk3s2 has 0 bytes of trailing loader space and  
it needs 134,217,728  
Problems were found with the partition map which might prevent booting.

This was on 2 out of 3 almost identical Toshiba drives, all 3GB -
2x DT01ABA300 &
1x DT01ACA300
Both the ABA drives gave the same error including that very specific 134,217,728 bytes.
The ACA 3TB & another 4TB Toshiba came up clean.

Steps taken so far to solve this...

There was an entire episode of trying to 'fix' the snapshots on the boot drive which you can read about on MicroMat's forum but is now irrelevant, I think. The drive itself passed all tests.

I sacrificed the Time Machine drive [an ABA] to give me room to move data without losing it.
Boot drive clones were done using Carbon Copy Cloner.
The 3TB HDs were done using Paragon Hard Disk Manager, because it's supposed to handle Boot Camp partitions better.
I reformatted the SSD & the 2 erroring 3TB drives, in such a way that each set of volumes ended up on a different physical drive [this becomes very relevant.]
So, what was the 'clean' time machine drive became a multi-volume data drive instead & the 'dirty' drive became a clean Time Machine drive.

I also cloned the boot drive to HFS+, reformatted the SSD as APFS & cloned back - thinking this way I wouldn't be carrying any snapshot or container data.

Afterwards, all drives check clean.
This was the point at which I re-installed High Sierra over the top of the existing boot drive to regain a Recovery Partition. Re: Add Recovery Partition to APFS drive?

24 hours later... Time Machine errors again.
It had completed the first full backup & presumably several incremental overnight. The boot drive shows 16 snapshots. Two of my 3TB drives display the exact same error as before.

but this is the puzzling part.
The erroring 3TBs are not the same two drives as before... nor do they contain the same volumes as before. Previously, the two ABA's errored, containing Time Machine & '4 volumes' respectively.
Now one ABA & one ACA are erroring, the '4 volumes' are now on one ABA when they used to be on the other, but the ACA was never touched. Time Machine is now on one of the previously erroring ABA's but has no errors.

The boot SSD comes up clean.

I'm completely out of ideas.
Other than these obvious underlying errors, I'm not seeing the machine misbehave at all.
Please let me know what diskutil commands might be useful in diagnosing this, or any other steps I could take to triage.

Late edit:
I uninstalled BitDefender & Time Machine appears to be behaving again.
I'm still monitoring. ...& failed again 2 hours later :/

2

Not much of an answer, but I eventually solved both this issue & also Notification Centre - What happened to Calculator widget? by cloning the drive, reformatting to HFS+ & cloning back again.

No amount of messing with APFS would fix it.

Late Edit:
Some time later I now have two of the ABA/ACA & the odd one out, an HDWQ Toshiba drives giving the odd "Volume [name] on disk4s2 has 0 bytes of trailing loader space and it needs 134,217,728 bytes" error.
Always that precise number.

Late Late Edit:
All this trouble went away with Mojave [mainly]. I have found that periodically I need to run DiskWarrior over the Time Machine drive, if anything starts to play up, but only every 6 months or so.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .