0

I recently installed the macOS Mojave developer beta on my MacBook Pro. Everything worked fine and I could start both macOS and Windows.

Today, when updating to the beta 2, however, the installation got stuck at 16 minutes remaining for over an hour at which point I force restarted the computer.

macOS still boots fine. Also Windows still appears as an option when I hold down the ⌥ (Option) key on boot. However, when I click on it macOS starts instead.

In Disk Utility a disk is not mounted and I cannot repair it. There is only one 512GB SSD that macOS and Windows share. Disk Utility

diskutil list outputs the following:

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         120.0 GB   disk0s2
   3:       Microsoft Basic Data                         379.5 GB   disk0s3
   4:           Windows Recovery                         491.8 MB   disk0s4

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +120.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            75.9 GB    disk1s1
   2:                APFS Volume Preboot                 23.3 MB    disk1s2
   3:                APFS Volume Recovery                510.5 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

How to get Windows 10 to boot again?

2

A workaround I have discovered is to go to System Preferences -> Startup Disk, and select the OS that you cannot now access from the boot screen as your default startup OS (in my case Boot Camp Windows 10). Then at the boot screen you can access Mojave as normal when you want to. It is not really a fix but an easy workaround until the fix comes out. It worked for me at least.

  • That’s a nice workaround in the meantime, workarounds like this are encouraged! – grg Jul 1 '18 at 9:07
  • Unfortunately the Bootcamp partition does not appear in the list, probably because it is BitLocker encrypted. – John Jul 12 '18 at 12:29
  • Is this encryption something you have added? Bootcamp certainly appears in my list even after the latest beta update, and the workaround still works for me. – Hugh Somerville Knapman Jul 14 '18 at 8:11

You must log in to answer this question.

protected by bmike Jul 6 '18 at 3:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .