2

I just updated to High Sierra, but managed to hang the setup assistant after install (I tried to open a URL). I force-rebooted the Mac, and the setup assistant was gone. How do I bring it back?

Removing /var/db/.AppleSetupDone brings back the initial setup assistant, but that's not what I'm looking for. I tried removing /var/db/.AppleDiagnosticsSetupDone, but nothing happened after I rebooted.

  • Try restarting and holding down the Option key. You may see an installed option as a disk. Select that one. – JBis Jun 21 '18 at 20:35
  • Wouldn't that just boot OS X normally? – SilverWolf Jun 22 '18 at 15:12
  • If you were mid update it may boot to the installer and finish the update. I have only seen this once though so not sure if it will work in your scenario. – JBis Jun 22 '18 at 15:18
  • Huh. No, in my case, it seems the update finished completely. When I booted up again, it acted completely normally. I've been using it after that with no problems so far. (I ended up going to the initial setup assistant, making a temporary user account in the process and deleting it afterwards.) – SilverWolf Jun 22 '18 at 15:23
  • Oh. I’m an idiot. I read question wrong. Disregard. – JBis Jun 22 '18 at 15:25

You must log in to answer this question.

Browse other questions tagged .