0

My Mac Pro ran with Mac OS X 10.10 until last week. I split the disk into two partitions, mirrored the OS and updated it on one partition to macOS 10.13. After the update I changed the startup disk and rebooted 10.10, changed the startup disk again and rebooted 10.13. Worked like a charm.

For debugging purposes, I booted 10.10 again today. However, I'm not able to select the 10.13 partition as a startup disk. I guess this is due to the "on the fly" migration from HFS+ to APFS, which wasn't finished when I tried booting from 10.10 immediately after the update. Now that it is finished, 10.10 doesn't understand the content of the APFS partition anymore, thus I can't select it as a startup disk in system preferences.

The Mac Pro is located in a data center, and I don't have physical access. So I can't hold any keys while booting. Hence, to change the boot device, I tried bless. Therefore I need the partition or device. As the partition is unknown to the current system, I have to use the device mode.

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2: 7C3457EF-0000-11AA-AA11-00306543ECAC               250.7 GB   disk0s2
   3:                  Apple_HFS Macintosh HD 2          249.3 GB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *36.0 TB    disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS storage             36.0 TB    disk1s2

I think disk0s2 is the APFS device as disk0s3 is the current partition:

$ mount
/dev/disk0s3 on / (hfs, NFS exported, local, journaled)
...
$ sudo bless --device /dev/disk0s2 --setBoot --nextonly --verbose
EFI found at IODeviceTree:/efi
found ioreg "FirmwareFeaturesMask"; featureMaskValue=0xFF1FFF3F
found ioreg "FirmwareFeatures"; featureFlagsValue=0xE90FF536
isPreBootEnvironmentUEFIWindowsBootCapable=1
given BSD is not a DVD disc medium
isDVDWithElToritoWithUEFIBootableOS=0
Checking if disk is complex (if it is associated with booter partitions)
GPT detected
Booter partition required at index 3
System partition found
Preferred system partition found: disk0s1
Returning booter information dictionary:
<CFBasicHash 0x7fb449608e10 [0x7fff7d70aed0]>{type = mutable dict, count = 3,
entries =>
    0 : <CFString 0x10fab5970 [0x7fff7d70aed0]>{contents = "System Partitions"} = (
    disk0s1
)
    1 : <CFString 0x10fab6150 [0x7fff7d70aed0]>{contents = "Data Partitions"} = (
    disk0s2
)
    2 : <CFString 0x10fab6170 [0x7fff7d70aed0]>{contents = "Auxiliary Partitions"} = (
)
}

IOMedia disk0s2 has UUID A1F6614F-C788-4009-951D-83019FECDEC8
Setting EFI NVRAM:
    efi-boot-next='<array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>A1F6614F-C788-4009-951D-83019FECDEC8</string></dict></dict><key>BLLastBSDName</key><string>disk0s2</string></dict></array>'
Setting EFI NVRAM:
    IONVRAM-DELETE-PROPERTY='efi-boot-file'
Setting EFI NVRAM:
    IONVRAM-DELETE-PROPERTY='efi-boot-mkext'
Setting EFI NVRAM:
    IONVRAM-DELETE-PROPERTY='efi-boot-kernelcache'
NVRAM variable "boot-args" not set.

However, the machine restarted with 10.10. I also tried to use the partition name:

$ sudo bless --mount /Volumes/Macintosh\ HD --setBoot --nextonly --verbose
EFI found at IODeviceTree:/efi
No mount point for /Volumes/Macintosh HD
Can't determine mount point of '/Volumes/Macintosh HD'
No BootX creation requested
No boot.efi creation requested
Could not statfs() /Volumes/Macintosh HD
Could not determine filesystem of /Volumes/Macintosh HD

Did I use the wrong command? Missing an argument? Or is there any other way of setting the boot device so that the machine starts with 10.13 again?

  • What happens when you boot while holding the Option key? Do you see the AFP partition? – Zonker.in.Geneva Jun 19 '18 at 13:06
  • @Zonker.in.Geneva Ah, sorry, I forgot to mention that the Mac Pro is in a data center and I don't have physical access. Sorry. I'll edit the message right away. – PVitt Jun 19 '18 at 13:11
  • you're using Disk Utility or diskutil from the command line? if you type "diskutil list" does that give you any clue? – Zonker.in.Geneva Jun 19 '18 at 13:35
  • @Zonker.in.Geneva Thanks. I added the output to the question. – PVitt Jun 20 '18 at 6:26
  • I’m not 100% sure, but I’d say, try disk0s3... – Zonker.in.Geneva Jun 20 '18 at 10:35
0

I believe you are S.O.L. here. Due to the haphazard way Apple has introduced APFS and instantly made it the default filesystem for 10.13 all at once, the only way to do what you are trying to do is to boot holding the option key. 10.12 and older won't let you choose your 10.13 volume because those OSes can't read APFS.

Apple has has many similar introductions in the past, but they did them right. They introduced support for something, then a few OS versions later THEN they make it default. APFS was released instantly, with with no support at all from third party apps, no support even from 10.12. Its a true clusterfuck and I suggest people wait an OS version or two before they switch to it. 10.13 runs just fine on an HFS+ volume.

  • Well, I do have the same feelings about this breaking change, however, I can't believe that I cannot instruct the boot loader to look for a system on a given device (as I tried with /dev/disk0s2). – PVitt Jun 20 '18 at 12:04
  • To the best of my knowledge, there is no way to do it due to the very irresponsible way apple implemented the new filesystem. That said, I don't know everything so maybe there is some really obscure way to do it. If you rm -rf / the 10.10 OS, then had your data center do a hard reboot, it might boot 10.13. Maybe. – l008com Jun 20 '18 at 19:22
  • Sadly, I had to restore 10.10 onto the 10.13 partition... – PVitt Jun 21 '18 at 13:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .