0

Is there a detailed way to fix and prevent this? and how do you completely install the 0.11.2 version of rEFInd? for further detail, it was installed on USB flash drive a few months back. and even now I still can't figure out how to completely install it the right way and keep having uninstall it to reinstall it because I'm honestly lost. here is a screen shot after hitting disk util list.

enter image description here

enter image description here

can you see it at bottom?

enter image description here

first thing I tried doing was following and doing these steps here in screenshot. and I got a message telling me at bottom copying sample files and to edit the file to configure refind. I forgot to take screenshot of that but oh well. enter image description here

but that got nowhere so thought I try mountESP script right after doing step 4 because I didn't get a installation message or, nothing like it, I don't remember seeing one at all. and ESP wasn't mounted after I typed mkdir /volumes/ESP and typing sudo mount -t msdos /dev/disk0s1 /Volumes/ESP

and still didn't mount. I have screen shot showing message telling me /volumes/ESP is not currently mounted when I tried to unmount it.even tried using mounts script and that didn't even get job done, it didn't mount.I even use a MacBook Air and it's version 10.13.6 because I just a short while ago updated my OS X firmware. enter image description here

I also tried these commandlines from the answers to a person's question post asking "How can I completely remove rEFInd from my Mac?" before getting that message telling me it's not currently mounted, then I decided to try LibreBowski YouTuber's method afterward thinking I got refind completely removed and uninstalled, I didn't, ran the command lines the youtuber recommended and then drag and dropped the refind-install script and got this:

Messengers-MacBook-Air:~ messengerm$ sudo mkdir /volumes/efi
Password:
Messengers-MacBook-Air:~ messengerm$ sudo mount -t msdos /dev/disk0s1 /volumes/efi
Messengers-MacBook-Air:~ messengerm$ /Users/messengerm/Downloads/refind-bin-0.11.2/refind-install 
Not running as root; attempting to elevate privileges via sudo....
ShimSource is none
Installing rEFInd on OS X....
Installing rEFInd to the partition mounted at /Volumes/efi
Found rEFInd installation in /Volumes/efi/EFI/refind; upgrading it.
Copied rEFInd binary files

Notice: Backed up existing icons directory as icons-backup.
Existing refind.conf file found; copying sample file as refind.conf-sample
to avoid overwriting your customizations.

Messengers-MacBook-Air:~ messengerm$ 

enter image description here

enter image description here

also by the way, I did Install refind directly on OS X and still got legacy os zipper icon with an extra real OS X boot icon with small bootable disk logo over OS X(it appears as bootable X icon)

enter image description here and I should add I mistakenly corrupted my internal apple hdd on Mac mini I previously used. I got other stories about it but I'm not going to mention it in this post.

I honestly used somebody's youtube video for removing refind boot manager utility then after... dumb ol me I got curious, typed cd /volumes;ls and cd ./efi;ls just to see a minimal text editor pop up because I never saw it before. sorry.

so my question is how can I truly completely wipe rEFInd off of OS X so I can get it installed completely and successfully so I can add things to it(optionally) and move on to installing another OS? enter image description here]9

closed as unclear what you're asking by fsb, Allan, IconDaemon, Ɱark Ƭ, Steve Chambers Jun 19 '18 at 20:58

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • also how do edit my question posts? – user291594 Jun 18 '18 at 18:30
  • There should be an edit button at the bottom of your post. – pixelomer Jun 18 '18 at 18:33
  • It's probably just a non-OS hard drive or partition. – Wowfunhappy Jun 18 '18 at 19:04
1

You can follow this tutorial even if you don't know how to use a terminal.

If you don't want to scan legacy operating systems, do the following:

The reason this is happening is because rEFInd scans for legacy operating systems as well by default. These steps will help you disable legacy OS scan.

  1. Open Terminal. Search for it in spotlight.
  2. Type diskutil list, press enter and identify your EFI partition. By default it is disk0s1, but if it is different for you, then you should use the right identifier.
  3. Type diskutil mount disk0s1 and press enter. The EFI partition should be mounted now.
  4. Type cd /Volumes; ls and press enter. A list of mounted partitions will appear. If you see "EFI", then continue the tutorial normally. If not, look for "ESP", "Untitled" or "Untitled X" where X is the highest number possible. Use that for the next step instead of "EFI".
  5. Type cd ./EFI; ls and press enter. From the list, find the folder that has the word "refind" in it, and use it for the next step. It can just be "refind" too.
  6. Type cd refind; ls where you replace "refind" with the right folder name if it is different. You will now see the files inside the rEFInd folder. Search for refind.conf. If you can find it, type nano refind.conf. If you can't find it, then there is a problem and you should reinstall rEFInd.
  7. You will be presented with a minimal text editor. Press Control+W, type scanfor and press Enter. It will find the nearest scanfor. If the cursor is at the first or the second character of a line now, continue to the next step. If not, repeat this until the cursor is at the beginning of a line.
  8. If the first character is #, press Backspace once.
  9. Using the Right Arrow Key, move the cursor to the end of the line, and delete everything with Backspace key except scanfor and the space after it.
  10. Type the following: internal,external,optical,manual.
  11. Press the following key combinations one at a time: Control+o, Enter, Control+X.

Try rebooting now. Legacy should be gone!

(Edits are appreciated, I might not be clear enough)

  • So you installed rEFInd on flash drive? Then your disk will be something like disk2s1. – pixelomer Jun 19 '18 at 8:55
  • this is what came up when I hit diskutil list. TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *123.0 GB disk3 1: EFI EFI 209.7 MB disk3s1 2: Microsoft Basic Data REFIND 122.8 GB disk3s2 so should I use bottom? – user291594 Jun 19 '18 at 9:31
  • Please edit your question and include the output there, it's unclear when it is a comment. – pixelomer Jun 19 '18 at 9:32
  • ok................. – user291594 Jun 19 '18 at 9:36
  • By the way, why did you install rEFInd on a flash drive? You can directly install it on your computer's SSD/HDD with the script that comes with rEFInd. If it's because of SIP, you could just install it from Recovery, no need to disable SIP. – pixelomer Jun 19 '18 at 9:38