4

I have a 15" MacBook Pro 2017 running High Sierra 10.13.5. I use 2 external monitors, one at home and one at work.

MacBook won't recognize output audio device from monitor when I plug it in. It doesn't show up in the sound menu bar either, all sound is coming out of internal speakers each time.

This started happening recently, past week or two. It only works if I restart MacBook, but I have to do it each time I connect it to the external display. The problem is not specific to one monitor either, as it happens with two different monitors.

Any ideas? Thanks

  • 1
    Try powering cycling the monitor to see f the audio get's detected. – Allan Jun 18 '18 at 10:47
  • @Allan I tried that, it's not helping. – nejckorasa Jun 20 '18 at 6:08
  • There's a DisplayLink issue with 10.13.4 - it could be related: displaylink.com/downloads/macos – Allan Jun 29 '18 at 12:48
  • 1
    I have the same issue, started happening with last update, they can't seem to be able to reach a stable system in which all the basic features work. I have to restart the computer all the time to get the sound back. – octohedron Jul 12 '18 at 14:17

You must log in to answer this question.

protected by bmike Nov 3 '18 at 18:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .