1

My question is related to the following:

"Apache not working with user Sites folder on macOS 10.13 High Sierra"

I installed High-Sierra over Sierra, and all my localhost/~username/pages were inaccessible. I restored my backed-up Sierra system. Now I'm wondering if that /etc/apache2 directory would have worked on High-Sierra. It has a 'users' directory with username.conf setups for all the /Users who use this machine, each having their own web-pages in their own Sites, and their own sub-directories in /Library/WebServer/CGI-Executables.

Several wab-pages have <form action> .... </form> structures that send <input name values> to scripts which process them and return web-pages, which may, in turn. be sent back for further processing. In other words, it's a design that allows a continuing dialog. Any thoughts?

  • Did you update your Server app after the macOS upgrade? – not2savvy Jun 17 '18 at 9:57
  • I tried a lot of things to get it to work, but there are no instructions about what to change. The 'httpd.conf' just points to '/Library/WebServer/Documents' as the place to put web pages, which would cause confusion between the several /Users who have individual Sites. And it seems all existing bookmarks would need to be revised in some fashion to reference existing html pages. Is there a tutorial on how to 'update'? – Dickster Jun 18 '18 at 17:06
  • PS: what do you mean by 'Server app'? My Mac is my server, and my browsers are my clients. – Dickster Jun 18 '18 at 17:11
  • Because you tagged your question with osx-server, I assumed you are using Apple‘s Server app to setup a web server. If not, please explain in your question how you‘ve setup your server. – not2savvy Jun 18 '18 at 22:12
  • By 'Apple Server app', do you mean on an iPhone? I have a Macbook Pro, and never heard of an 'Apple Server app'..Is there one built-in to High-Sierra? – Dickster Jun 20 '18 at 3:11

You must log in to answer this question.

Browse other questions tagged .