7

I see that my iBooks seems to be uploading my books to the cloud without keeping a copy on my local device. So when I reopen the app, I have to wait for the book to do finish downloading (which is a hassle if it is a 600 page pdf)

How can I prevent iBooks from deleting local book files and moving them to the cloud?

Is this related to “offload I used apps” switch? (it’s on for me)

1

Goto Preferences, uncheck options which reads Sync bookmarks, highlights and collections across devices

  • 1
    What if I still wanted my books (including bookmarks, highlights, collections) to be synced over iCloud, but not deleted from local storage automatically? – Bruno Ely Nov 12 '18 at 10:08
  • @BrunoEly so far couldn't find anything on it. – ankii Sep 10 at 21:05
1

This is a bug in iBooks. Please report it to Apple so they fix it. Many of us have this problem. I just got bit by it on an airplane flight, when I realized I didn't have my books on my iPad or phone because... Apple.

0

The answer lies the in the question itself. Go to iCloud preferences on your device and turn off iBooks. It will keep all the books offline and some other device say Mac can have its own set of books not being mixed with Those I’d say iPhone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .