2

I have macOS High Sierra running on my Mac, and it has worked fine until now. But today I experienced something very weird. I was trying to restart Apache (a web development server), and then my apps started reacting very weird. For example, I had Activity Monitor open, and then suddenly it crashed and when I tried to open it again, it either says "Activity Monitor is not open anymore." or just doesn't respond. And when I try to use Command Tab to switch to another app, it just gives me the sound that tells me that you cannot do that, and the same with Command Q and Command W. Not many of my apps are willing to open when I try to open them. After a while my keyboard even doesn't react when I type!

If I restart my computer, it is working fine in the start but when I try to restart Apache, it does all that crab again.

UPDATE: If I have an app that is not responding, lets say the Terminal, and I go to the menu bar and click Terminal > Quit Terminal, then suddenly the menu bar disappears.

What can I do to fix my computer?

  • 2
    Start off by booting into Safe Mode (hold Shift while booting) then test out to see if the symptoms persist. – Allan Jun 17 '18 at 11:28
  • I just ran into this problem myself with Mojave trying to run Apache. Did you ever find out the cause/solution? – Hiram Hibbard Nov 18 '18 at 16:40
  • I don't really remember if it fixed itself after some updates or something, but have you tried the suggestion by @Allan? – Victor F Nov 30 '18 at 20:25
  • @HiramHibbard Check out my answer – Victor F Jul 10 at 9:36
1

I found a somewhat working solution.

I am using Homebrew's httpd package, so I found out that I could just reinstall it:

  1. When it begins to do that weird stuff, restart the computer.
  2. Then reinstall httpd with brew reinstall httpd
  3. You're good!
  • 1
    Instead of using homebrews apache, you could also stick with the defult provided by MacOS. – Jdrupal Jul 10 at 11:33
  • The reason I do this is because I used this guide, which uses Homebrew's Apache instead of the native apache. – Victor F Jul 10 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .