Does anyone else have issues while trying to use new App Store on macOS? I can log in but I can't download or update any app.

Sometimes it asks me to change App Store country to one linked with logged in Apple ID (Croatia) and when I try to change it App Store gives me error ‘Cannot connect’.

Restarting Mac didn't helped.

How to solve this issue?


2 Answers 2


With latest beta 2 update 10.14 Beta (18A314h) issue is resolved.

  1. Update macOS to latest 10.14 Beta (18A314h)
  2. Open App Store
  3. Click on Store -> Sign Out in menu
  4. Quit App Store
  5. Open App Store again
  6. Sign in

After this I could update apps and initiate new downloads.

  • Thanks this worked. Turns out I was signed into the wrong country in the new app store app - I guess based on my physical location. When I logged in it said it would switch me to the US app store, and now it works again.
    – n13
    Oct 24, 2018 at 1:39

macOS Mojave is currently in early beta phases. The stable public release is due in fall.

Such unintended behaviours may appear due to the nature of the release.

  • 1
    Thank you for answering me. I do understant it's an early beta and it will probably be fixed in the future releases, just asked to see if there are any solutions right now and if anyone is having similar issues. I've filled radar for this problem. Jun 15, 2018 at 13:17
  • 2
    Filing radar certainly helps.
    – Nimesh Neema
    Jun 15, 2018 at 13:18
  • Well for me it happened in the production release so this question / answer below was helpful. Seems like that bug was in beta but didn't get fixed...
    – n13
    Oct 24, 2018 at 1:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .