6

The Messages app on my Mac is showing a persistent badge which isn't going away. The app icon is consistently showing a count of 3 which has remained intact despite doing the following:

  • Exchanging messages with multiple recipients.

  • Clearing all the messages (from Messages on Mac as well as on all the linked devices).

  • Disabling/Enabling the iMessage account (on my linked Mac, iPhone and iPad).

  • Disabling/Enabling Messages in iCloud (on my Mac).

  • Disabled/Enabled Text Messages forwarding from iPhone to Mac and iPad.

I have set up my iPhone to automatically forward Text Messages to my Mac and iPad.

My iOS devices are running iOS 11.4 and Mac is running macOS High Sierra 10.13.5.

Note that the count on the icon is not just incorrect, it is persistently stuck at number 3. Count on iOS devices are appearing correct.

When there are unread messages, the count is shown correctly to reflect the number of unread messages. As soon as all the messages are read/deleted, the count goes back to 3.

I have a single Mac linked to my Apple ID. How do I proceed with getting rid of this incorrect count badge?

enter image description here

enter image description here

Right clicking the Messages icon in the Dock shows three numbers as shown below. However, no message is shown in the Messages windows.

enter image description here

  • 2
    Let me know if you'd like an answer that punts this entirely. I tried twice to track this down and ended up deleting the user account (after checking that the files I cared for were backed up) and then made a new user account. I sincerely hope someone knows how to reset that more surgically and we both can learn. – bmike Jun 15 '18 at 11:46
  • 1
    Do share your answer @bmike. I believe I have encountered yet another bug in macOS. I do not have "any" data on my Mac that I am worried of losing (I hardly keep any of my data locally on devices). – Nimesh Neema Jun 15 '18 at 11:50
  • 2
    This happened to me a few weeks ago so I'm trying to remember how I fixed it. When you right-click the Messages icon, does it show an email address or phone number as the 'unread' messages? – fsb Jun 15 '18 at 13:32
  • 1
    Can you clarify right clicking the Messages icon where? In the Dock, Finder? – Nimesh Neema Jun 15 '18 at 13:33
  • 2
    Sorry, the Messages icon in the Dock. When you do that, you should see what's generating any unread message. It's usually a phone number or email address. I think for me it was a message from an 'Unknown Sender' on my iPhone. I never look there so didn't see it. – fsb Jun 15 '18 at 13:40
9

None of the other answers really solved it for me. After killing the Dock or signing out and back in, I'd have the badge return eventually.

So in Finder I went to ~/Library and searched for the listed phone number. It showed me a file in ~/Library/Messages/Archive/yyyy-mm-dd/ that was named for the phone number. Deleted the file and then killed the dock (by executing killall Dock in the Terminal) and the badge was gone instantly.

I have also figured out the cause: deleting a message on your iPhone or iPad without reading it. It's always an automated message with a 2FA code or something, and that's because I could see the code and typed it in and then deleted the thread later because I always trash that junk.

  • Perfect! This resolved the issue for me too. Thanks. – Nimesh Neema Jul 29 '18 at 12:54
  • I had to kill Messages before killing the Dock $ killAll Messages – TimD Oct 7 '18 at 10:02
2

I've had two cases where that bubble remains even after I signed out of Messages entirely and then signed out of my AppleID everywhere (FaceTime, iCloud, App Store, iTunes, etc... which is everywhere I can think of - perhaps I missed a spot) so I'm thinking there's some chance there's a bug in the database(s) that track this and clearing that will be quite difficult.

On these two cases, I just set up a temporary admin account and logged out of the main account. Then I did a proper backup (Time Machine or other) and deleted the offending user account. Once you clear the home folder /Users/whatever - then I made a new user account with the same short name (or different if you please) and copied back only the working files - not the settings.

This has fixed the Messages count for both cases - so it wasn't really a problem online - more of a local database corruption that I wasn't clever enough to pick apart and locate what set of files or database held the wrong unread badge count.

It's a very indirect fix and lots of work, but the new account olympics did help when I don't know precisely how to zero the count.

0

Ran into this once myself. Launched FaceTime, went to the Audio tab at the top and the badge app icon count immediately cleared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .