2

We used a Mac Pro running server app as time machine target. The Mac Pro is on a different subnet, so we had to add it as a time machine target via command line:

sudo tmutil setdestination -ap afp://user@host.domain.tld/timemachine

This worked pretty well on several machines. Today, I upgraded the Mac Pro from OS X 10.10 and Server 5.0 to macOS 10.13 and Server 5.6. This means, the time machine target stuff was moved from the server into the operating system. I checked the sharing settings:

System Preferences -> Sharing -> File Sharing -> timemachine, rightclick -> Advanced options:

Share over "SMB and AFP"

Share as Time Machine backup destination checked

Next thing I tried was a TM backup on my local machine. Failed with error The network backup disk does not support the required capabilities. My first idea was to resetup my local Time Machine. I thus removed the TM-target and tried to readd it:

sudo tmutil setdestination -ap afp://user@host.domain.tld/timemachine
Password:
Destination password:
Disk does not support Time Machine backups. (error 45)
The backup destination could not be added.

Same result with SMB instead of AFP.

Then I tried to run a backup on a different machine, same error as above. This machine still has the Mac Pro as a TM target as I didn't remove it yet.

I checked the logs on my local machine and found that TM is trying to use /Volume/timemachine-4 as target. mount told me that there are several mounts to the Mac Pro, thus I unmounted everything and restarted my local machine. After that I was at least able to readd te Mac Pro as TM target (via AFP). But a backup resulted in the same error again: The network backup disk does not support the required capabilities.

Does anyone know which required capabilities are not provided (anymore)? Or do I need to open additional ports in the firewall between the two subnets?

Update 1

After trying this and that, I again removed the TM target, but can't readd it, even after a reboot. However, the log tells me (when trying to mount via AFP):

kernel: (afpfs) AFP_VFS afpfs_vnop_ioctl: SyncDir failed 22 backupd: (TimeMachine) [com.apple.TimeMachine:TMLogError] Mountpoint /Volumes/timemachine does not support required Time Machine capabilities!

But I also see (besides some other NetAuthSysAgent messages)

(AppleShareClientCore) ERROR: AFP_OpenSession - Login failed with 80

Don't know whether this indicates a problem or is normal operations, e.g. due to falling back to some other authentication.

Update 2

The target share point on the Mac Pro is on a Thunderbolt attached Lacie device, which is still on the old Mac OS Extended (Journaled) file system. Could this be the problem?

0

There is a Lacie Raid attached to the Mac Pro. The Raid runs on HFS+, which doesn't get changed to APFS when updating the system to macOS 10.13 High Sierra. However, it seems that backing up onto a volume with HFS+ file system is not supported anymore.

I created another share on the system disk, which is APFS by now, and was able to back up onto this disk. Conclusion: Time Machine targets have to reside on APFS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .