1

I know this question has been answered a few times before in relation to other monitors and Mac OS X versions, but due to my limited knowledge I am after specific help with my setup.

I have a 2012 MacBookPro running Mac OS X Mavericks 10.9.5. I usually use a thunderbolt display with no problems, enjoying all resolutions on offer. I have just bought a Philips QuadHD 27" monitor (272B8QJEB/75), capable of 2560x1440, but am only getting max. 1920x1200. Yes, I have tried the option-click on the 'scale' drop down and I am using a 4K compatible cable. Is it possible to get the full resolution on this external display? I have seen fixes for other monitors and osx versions posted here.

Admittedly my knowledge is limited so a walkthrough would be greatly appreciated if there is a fix. I would prefer not to update to macOS Sierra as certain software I use will no longer work.

  • How are you connecting to your display? HDMI? DVI? DisplayPort? And if HDMI or DisplayPort, what spec are they HDMI v1.4+ or DP 1.2+? – Allan Jun 14 '18 at 10:58
  • Hi Allan, I'm connecting via mini DisplayPort to HDMI, 4K compatible. I have a Mini DisplayPort to DisplayPort cable on the way, but everything I read says this 4K compatible cable should do exactly the same thing. I'm looking to the issue that others have encountered which is the that the mac is recognising the display as a YCbCr device and needs a display override file created to force Mac OS X to use RGB mode for Display. . ? – Caslon Jun 14 '18 at 12:19
  • Most likely, you need an active adapter - see this answer: apple.stackexchange.com/a/268284/119271 – Allan Jun 14 '18 at 12:49
  • The cable is already HDMI 2.1 / 4K. I wish it was as simple as the cable! – Caslon Jun 14 '18 at 14:31
  • I'm looking for a solution similar to the one discussed here: apple.stackexchange.com/questions/106933/… – Caslon Jun 14 '18 at 14:36
1

According to Apple, my MacBook Pro model will not support external monitors other than theirs. If I was to upgrade my MacBook I could use the screen I bought.

0

Hold down the option key when you click "scaled" and additional resolutions should become available.

  • as stated in my post, this does not work. This is a bigger issue than that. – Caslon Jun 14 '18 at 7:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .