Keep popping up this window if I don't click "Allow". How can I disable it if I don't click "Allow"?

enter image description here

enter image description here

After a period of time, will collapse to restart.

enter image description here

Anonymous UUID:       A82E64D9-FCAE-DEF8-9400-AFFFC3CB8A33

Thu Jun 14 13:35:26 2018

*** Panic Report ***
panic(cpu 2 caller 0xffffff800f10d08d): Kernel trap at 0xffffff800f611e7b, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0xffffff7f92537768, CR3: 0x0000000012e45000, CR4: 0x00000000001627e0
RAX: 0xffffff91ffc053e0, RBX: 0x0000000000007d3e, RCX: 0xffffff7f92537768, RDX: 0x0000000000030360
RSP: 0xffffff922a893c40, RBP: 0xffffff922a893c80, RSI: 0xffffff802f57f3a0, RDI: 0xffffff802f14b8e0
R8:  0x000000000056e1e0, R9:  0x0000000000000000, R10: 0x0000000002e3e614, R11: 0xffffff81adfb8360
R12: 0x0000000000000000, R13: 0xffffff802f57f3a0, R14: 0xffffff802f14b8e0, R15: 0xffffff802f14b8e0
RFL: 0x0000000000010282, RIP: 0xffffff800f611e7b, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0xffffff7f92537768, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 1

Backtrace (CPU 2), Frame : Return Address
0xffffff922a8936f0 : 0xffffff800efe2c3d 
0xffffff922a893740 : 0xffffff800f11b373 
0xffffff922a893780 : 0xffffff800f10ceb4 
0xffffff922a893800 : 0xffffff800ef90c80 
0xffffff922a893820 : 0xffffff800efe2657 
0xffffff922a893940 : 0xffffff800efe24a3 
0xffffff922a8939b0 : 0xffffff800f10d08d 
0xffffff922a893b30 : 0xffffff800ef90c80 
0xffffff922a893b50 : 0xffffff800f611e7b 
0xffffff922a893c80 : 0xffffff800f611df8 
0xffffff922a893ce0 : 0xffffff800f611758 
0xffffff922a893d00 : 0xffffff800f611721 
0xffffff922a893d30 : 0xffffff800f5f1e41 
0xffffff922a893d60 : 0xffffff800f5f1c06 
0xffffff922a893d80 : 0xffffff800f5f1e53 
0xffffff922a893db0 : 0xffffff800f5f1c06 
0xffffff922a893dd0 : 0xffffff800f5f41e6 
0xffffff922a893e10 : 0xffffff800f5f1e53 
0xffffff922a893e40 : 0xffffff800f602dd2 
0xffffff922a893e90 : 0xffffff800f606696 
0xffffff922a893ed0 : 0xffffff800f01e4e4 
0xffffff922a893f40 : 0xffffff800f01e075 
0xffffff922a893fa0 : 0xffffff800ef8fffe 

BSD process name corresponding to current thread: kernel_task

Mac OS version:

Kernel version:
Darwin Kernel Version 18.0.0: Fri May 25 16:54:22 PDT 2018; root:xnu-4903.
Kernel UUID: A7F4AE1A-A080-3185-9F4C-75CC93A456D0
Kernel slide:     0x000000000ec00000
Kernel text base: 0xffffff800ee00000
__HIB  text base: 0xffffff800ed00000
System model name: MacBookPro11,2 (Mac-3CBD00234E554E41)

System uptime in nanoseconds: 593821175757
last loaded kext at 259044968492: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7f9250b000, size 69632)
last unloaded kext at 20778300123: com.netease.nemu.kext.NemuDrv    5.0.20 (addr 0xffffff7f92501000, size 401408)
loaded kexts:
com.cisco.kext.acsock   1.1.0
com.intel.kext.intelhaxm    6.2.1
com.splashtop.driver.SRXFrameBufferConnector    1.6
com.splashtop.driver.SRXDisplayCard 1.6
com.apple.filesystems.msdosfs   1.10
com.apple.filesystems.smbfs 3.3
com.apple.driver.AudioAUUC  1.70
com.apple.driver.AGPM   110.23.39

There is a workaround for this. I don't recommend it from a security perspective, but it does get you back to the behavior of macOS 10.12 until Cisco gets around signing the kernel extension for your VPN client.

Basically, you can turn off the security feature requiring user approval of Kernel Extensions.

First, boot into Recovery Mode by rebooting and pressing and holding command-R as soon as you see the Apple logo.

Eventually you will see a screen that gives you a couple of options, including reinstalling or running Disk Utility.


If you look at the menubar at the top, you will see a "Utilities" drop-down menu. Click on that and select Terminal. A window will open up that allows you to type text-based terminal commands.

You will see a "$" prompt in the terminal window. Type the following:

spctl kext-consent disable

then press Return. You should see:

Kernel Extension User Consent: DISABLED

Please restart for changes to take effect.

Then reboot your Mac, and you should be good. You will no longer see the notification panes telling you a Kernel Extension was blocked; they will all be automatically allowed, just as they were in macOS 10.12.

Don't forget to re-enable kernel extension verfication after the full release of macOS 10.14.

spctl kext-consent enable

For more information, see the following User Approved Kernel Extension:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .