1

I have just updated my Mac to High Sierra 10.13.5 and my account which used to be admin has now became standard. It seems I no longer have an administrative account and no solutions worked so far. I have tried resetpassword (doesn't allow me to set admin); .AppleSetupDone (seems this file doesn't exist anymore?); Single User Mode (two ways of using it, one is to boot and delete the applesetupdone file, the other is to create new user and set as admin). In the last solution, after dscl . -create/users/hanahadmin It appears /system/library/launchdaemons/apple.com.directoryserviceslocal.plist: No Such File or Directory

This happened at Terminal

I am not at all knowledgable at this and don't know many technical terms or skills, I just tried to follow the instructions but nothing works. I have found some people with the same problem as me. It seems that those who say they do not have AppleSetupDone file are struggling with every single solution, those who have the file say it works. Please help me on this matter! Many thanks.

enter image description here

I have tried several solutions, most are from this link I don't have administrator account on my mac

  • 1
    It looks like you're trying to do this in Recovery mode, not single-user. In Recovery mode, you are not started up from your normal system volume, so files are not at their usual paths. You'll have to use something like rm /Volumes/"Macintosh HD"/var/db/.AppleSetupDone Note that if your main volume is named something other than "Macintosh HD", you need to substitute that at the appropriate place; also, there must be a space after "rm" and cannot be one before ".AppleSetupDone". Also, standard dscl commands will not work as expected in Recovery mode. – Gordon Davisson Jun 14 '18 at 0:45
  • What @GordonDavisson said... However, type mount to see what mount points have been loaded so we can navigate you properly. – Allan Jun 14 '18 at 0:48
  • That picture was for Terminal only. And two attempts with different spaces was only me being frustrated. For SingleUser I pressed cmdS and it was a black screen with white characters like instructed. – Hanah Jun 14 '18 at 0:59
1

Wow. You certainly have done several steps to remove the AppleSetupDone file. I would try the most correct one

cd /private/var/db 
rm .AppleSetupDone
ls -la
exit

The ls is just to be sure. If that doesn’t workyoull need to reinstall the OS or erase install if you don’t need a backup. Let me know in comments how the last try to remove the setup file works? (all those allocation zone messages have me thinking your storage or data on it are messed up beyond easy repair)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .