4

I have an iPad that I have had for a while, I recently bought a new Mac. I have a lot of chat history on iMessage already on the iPad, is there a way to sync it to the messages app on the MAC?

  • 1
    Please edit the question to mention the version of software running on iPad (iOS) and Mac (macOS). – Nimesh Neema Jun 13 '18 at 13:05
2

After updating to iOS 11.4 or greater and macOS High Sierra 10.13.5 or greater you should be able to use iMessage on iCloud. This would allow you to sync your message data across iCloud, so when you sign in from your mac all your messages from your iPad appear on your Mac. To enable that settings follow the tutorial here.

Enable on iOS

Enabling this feature is simple. Open the Settings app, then tap the Apple ID settings with your name at the top of the page. On the Apple ID page, Tap "iCloud," then toggle on "Messages." If you have not set up two-factor authentication, Apple will walk you through the process here.

Once 2FA has been enabled, the Messages icon should be as well.

Once you enable the "Messages" toggle, when you open up the Messages app, it should say "Uploading Messages to Cloud" to indicate it's doing just that. If you're not connected to Wi-Fi and not plugged in to charge via USB, you will get an "Uploading to iCloud Paused" message stating to plug in your device and connect to Wi-Fi. Once it's done, the popups will disappear.

Enable on macOS

Now, you won't notice anything different about Messages right away. Most of Messages in iCloud's features are under the hood. However, if you are running the iOS 11.4 on another device or if your Mac is running macOS 10.13.5 (it needs to be enabled in the Messages settings), you'll notice what happens on one Messages app happens on the other.

If you enabled it on your iOS device already, you should get a prompt on your Mac to enable it. If not, open the Messages app, then click on "Messages" in the menu bar, followed by "Preferences." From there, click on the "Accounts" tab, and select the iMessage account listed on the left side of the window. If you haven't already, you may need to check the box that says "Enable this account." When that's good, check the box next to "Enable Messages in iCloud" (beta versions at one point called it "Enable Messages on iCloud").

enter image description here

If you don't see this option, you are likely still running iOS 11.3.4 and will need to update your software.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .