I enabled notifications for slack.com in Safari to get push notifications for new messages. However, I don't get any sound with those notifications. The just appear in the top right corner of the screen, but the Mac does not play any sound.

I am using Safari 11.1.1 in macOS 10.13.5.

Any ideas?


The setting in System Preferences → Notifications → Safari for ‘Play sound for notifications’ allows sounds to be played for notifications.

It's then up to the website to decide to provide a sound for Safari to play on a notification.

You can configure this for Slack in your preferences on slack.com.

| improve this answer | |
  • I had to change the sound notification in slack to something else and reverted to the sound I used before. It is now working. – WalterBeiter Jun 12 '18 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .