4

Every now and then, my media keys (F7, F8, and F9) keep randomly stop working with Spotify. I don't have any other media apps open, like iTunes or anything, just Spotify. A program restart doesn't solve the problem, forcing me to restart the entire computer for it to work. How do I fix this?

  • Are you a Chrome user? What are the applications open while you are listening? – Rushil Srivastava Jun 11 '18 at 18:20
  • I generally have IDEs open, and Chrome. PyCharm, Atom, and Sublime. Sometimes chatting applications such as Discord and Slack. – user405892 Jun 11 '18 at 21:27
  • Try restarting Chrome when you have the issue again in the future. Chrome often tries to utilize those keys for its own media control. I believe you can disable this somewhere in settings. – Rushil Srivastava Jun 11 '18 at 21:42
  • Fixed it, that worked. – user405892 Jun 12 '18 at 7:51
3

Seems like we were able to find the problem through the comments. Chrome sometimes "hijacks" your media buttons for its own functions. A quick google search yielded the following result:

You can set to the keyboard shortcuts to work only when Chrome is in focus:

  • Open the Chrome app menu
    • Select Tools > Extensions
    • Click the ‘Keyboard Shortcuts’ link at the bottom of the page
    • Find the Google Play Music section
    • Change any specified media key options from ‘Global’ to ‘In Chrome’
    • Fix Media Key Hijacking in Chrome image with keyboard shortcuts

Or you can disable/remove the app/extension from Chrome entirely:

  • Open the Chrome app menu
  • Select Tools > Extensions
  • Find ‘Google Play Music’
  • Uncheck the ‘Enabled’ box OR click the trash can to remove

image deleting extension

Source: OMGChrome

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .