0

I have the MacBook Pro (15-inch, 2017), a Samsung 4k display, and a USB-C to HDMI cable between them (plugged directly into the computer).

The entire setup supports everything necessary. Please don't say they need to be compatible.

After a lot of fiddling, I get it to do 4k@60Hz and it works perfectly - even piped the audio.

Then, something will happen - power flicker, I turn off/on the TV, take my laptop somewhere else, act of god occurs, whatever - and the computer will suddenly forget it can use 4k@60Hz.

Sometimes this is fixed by repeatedly unplugging/plugging-in the display, most times not.

I have the command-line utility screenresolution. Sometimes OS-X decides to use 30Hz even when it knows 60Hz is available. This utility can then change it for me.

Sometimes (like right now) I want to throw this computer off the roof because it refuses to believe it supports 4k@60Hz.

This is independent of OS-X version, independent of TV (this same issue happened with a TCL TV), and independent of cable (happened with a different brand of cable).

I tried some system-preferences extension which required me to turn off SIP to manually add custom modes, and that sometimes worked - but also sometimes caused the HDMI audio to not work, so I got rid of that.

How do I convince OS X that the monitor does and always will support 4k @ 60Hz?

In case it matters, I also have (on a different USB-C port) a USB-C/TB3 hub and its display-port output goes to the MDP-to-dual-link-dvi-adatper to a 30" Cinema Display, so I have the 4k@60Hz TV, the 30" Cinema Display, and the laptops display all acting as non-mirrored monitors.

This is the [active] cable I’m using: https://www.amazon.com/dp/B075V5JK36/ref=cm_sw_r_cp_api_i_3g9hBbY6VM4X5

  • 1
    Possible duplicate of MacBook Pro 13 (early 2015) with 4K Television: Can I get 60Hz? – Allan Jun 12 '18 at 13:29
  • 1
    The issue here, as in the linked dupe, is that you need to use an active adapter; not a cable that converts the signal. This is KEY when using things like HDMI (which is horribly flaky to begin with) – Allan Jun 12 '18 at 13:30
  • @allan No, this is not a duplicate. This IS an active adapter, and it DOES work - but sometimes OS-X doesn’t agree. If the problem were the wire being non-active, it wouldn’t ever work. But it does. amazon.com/dp/B075V5JK36/ref=cm_sw_r_cp_api_i_3g9hBbY6VM4X5 – iAdjunct Jun 12 '18 at 14:00
  • There's nothing on that page that says it's active. An active adapter is very different from a passive adapter. See: apple.stackexchange.com/a/275978/119271 – Allan Jun 12 '18 at 14:06
  • The HDMI end of the cable is large and quite hot, indicating there is an active chip there. – iAdjunct Jun 12 '18 at 15:23
1

I have the same problem, but with a MacBook 13" 2017, a Samsung 4K TV, and a USB-C to HDMI 2.0 active cable.

How to solve the problem: First connect the USB-C end of the cable to the MacBook, then after a couple of seconds connect the HDMI end to the TV while powered on. I got 100% success in having 4K @ 60hz using this procedure.

How is this possible: Not too technical, but... The active chip on the cable's HDMI end first powers up and initializes from connecting it to the USB-C port, and in sequence, the correct resolutions and refresh rates are offered as soon as the other end of the cable is connected to the TV.

I know this is not a proper solution, but at least it doesn't make me want to throw the MacBook out of the window!

I hope there's some more feedback from other users.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .