5

I've looked this problem up and it seems common but can be caused by a variety of reasons, I tried most of the solutions but the problem persisted.

The problem: the WiFi works fine as I can look up networks and connect to them and have a full signal. Also the Internet connection seems to be established because I can ping websites and use curl when I'm connected. But when I open safari or appstore or email I don't get a response and safari says "Safari can't open the page 'website' because safari can't establish a secure connection to the server 'websites server'. "

Solutions I tried:

  • cleared cookies

  • all proxies are off

  • time is set to the local time

  • removed the WiFi service and added it again

  • In the network configurations I tried to renew DHCP lease

  • and many small tweaks that I don't remember

Also I have an iPad which works just fine, so I really don't know what causing the problem.

  • 2
    Is Safari the only web browser that does not work, or do all web browsers exhibit this problem. This lengthy question on AskDifferent and it's detailed answer may provide a good starting point for troubleshooting the problem. – IconDaemon Jun 8 '18 at 21:17
  • Try pinging the website you are trying to reach, Network Utility has an option for this. Also, try a new user account and try safari in recovery mode. – John Keates Jun 9 '18 at 13:27
2

Does the internet work on another browser? (if you have another installed)

Have you tried clearing your DNS? (Click the Apple Icon and Choose System Preferences. Then click the Network icon and choose Advanced. Click the DNS tab and remove any entries in the left pane)


If you don't have any antivirus, VPN or firewall programs installed, then it has to do with the website. Their network encryption is weak and Apple wont let you use it. Which usually notes a certificate issue. Normally the site admin stays on top of this.

If Safari says it can't establish a secure connection, or the website is using weak encryption

To protect your security and privacy, websites must use strong encryption to provide a secure web connection.

Security enhancements in OS X Yosemite v10.10.4 and iOS 8.4 help protect against important security vulnerabilities. If a webpage is on a server that doesn't meet secure cryptographic standards:

  • Safari will say that it will not open the website because it's using weak encryption.
  • Or Safari will say that it can't open the page because Safari can't establish a secure connection to the server. To resolve the issue, the website administrator should configure their server to be secure.

How to Correct Certificates

If you only experience the error in Safari but not in other browsers, then open the blocked websites in another browser. Once you have it open, just next to the URL you will identify a tiny green lock, the word secure may be beside it. Click on it and it should show you a certificate option which shows you the current certificate details for that site.

You may see a label name that identifies the certificate. Some say Verisign or Digicert. The naming doesnt matter but you need to find it in your keychain.

Open up Keychain Access either with Spotlight Search (keyboard shortcut - CMD + Space Bar) or you can go to your LaunchPad (or Applications in Finder) and look for a utilities folder. It has Keychain Access in there.

With Keychain access open, click on system roots for all entries. You will find here your certificate by name and it will have a blue cross marked on it. Double click it and another window will come up. You have the option of choosing system setting, always approve or always reject.

You will realize that the certificate was the problem all along. Usually, a certificate will be locked on to the mail server and it will prevent any other website from using it. (Your mail server should be the entry starting with the “smtp” prefix and ending with a “.dk” suffix. Why the certificate would be locked to the mail server is as good as anyone’s guess.

Change the authentication of the certificate to “System setting


If none of this works, and you have no problems with other networks, then you need to contact the network admin and have them reset the router by powering it down, pulling out the plug for a few mins and then plug it back in and restart it.

If they have reset it and the issue still occurs, then there are some files either missing or corrupt with MacOS. I'd attempt a MacOS reinstallation (make sure you do a backup 1st) and see if things are different from there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .