8

A few months ago I decided to format an external HD that I wish to use with my Mac mini, but I can not use 100% of it.

In the formatting process, a partition called EFI appeared. When I open the Disk Utility app, the partition is not displayed, but it was displayed by the command line using diskutil.

Here is the Disk Utility:

enter image description here

From the command line: diskutil list

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS MAC HD                  881.0 GB   disk0s2
   3:         Microsoft Reserved                         16.8 MB    disk0s3
   4:       Microsoft Basic Data BOOTCAMP                118.9 GB   disk0s4

/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *640.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:       Microsoft Basic Data HD Caio                 639.9 GB   disk1s2

How can I recover the space lost to disk1s1?

2 Answers 2

11

EFI partition is a partition that stores boot files for operating systems, but since it is an external drive, it's not needed. When you erase your disk and create a new GUID Partitioning Table on it, macOS will automatically create an EFI partition. If you don't want that EFI partition, you have a few options:

  • You can erase your disk and create a new MBR instead of GPT. To do this, follow these steps:
    1. Open Terminal. You can use spotlight to find it
    2. Make sure your external disk is inserted. Type diskutil list and identify your disk (in the output you provided, it looks like it's disk1).
    3. Type diskutil eraseDisk JHFS+ MYDISK MBR diskX and replace diskX with the actual disk's identifier (for example, disk1)
    4. Your disk will be erased without an EFI partition now.
  • You can use diskpart.exe to partition the disk on Windows. Windows doesn't create an EFI partition.
5
  • I ran the command and the EFI partition simply disappeared instead of going back to the disk: /dev/disk1 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *640.1 GB disk1 1: Apple_HFS MYDISK 640.1 GB disk1s1 Jun 7, 2018 at 15:00
  • Should not partitions disk1s1 and disk1s2 merge? Jun 7, 2018 at 15:02
  • What do you mean? It looks like it's solved.
    – user255044
    Jun 7, 2018 at 15:02
  • 1
    They did. It was 639.9 GB and it merged with 200 MB so it's now 640.1 GB.
    – user255044
    Jun 7, 2018 at 15:03
  • There is a limit on the size of volume that MBR and APM can used on. I know that 4TB is too large. Essentially, for modern drive sizes, there is only one format... GPT, and it appears there is no way to remove the EFI partition and reclaim that space.
    – John
    Oct 1, 2023 at 0:37
0

This works for me, In Mac Terminal

Step 1. type command to get list of partitions

diskutil list

Step 2. to erase/remove EFI partition

diskutil eraseDisk JHFS+ MYDISK MBR disk2

Note : MyDisk is new name for your drive and disk to is the drive partition

Step 3. that,s it.. just check your new structure

diskutil list

EFI partition is gone!!

Step 4. Now remove your drive(USB) and connect to PC

Step 5. Just Format in normal way and start using.

1
  • Can't use MBR format on large single partition HDDs
    – John
    Oct 1, 2023 at 0:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .